Back to the main site

Can't install origin ibGL error

Installing origin does not work for me on arch, it ends with the error

lutris-wrapper: /home/andreas/.local/share/lutris/runners/wine/lutris-7.2-2-x86_64/bin/wine
Started initial process 34991 from /home/andreas/.local/share/lutris/runners/wine/lutris-7.2-2-x86_64/bin/wine /home/andreas/Downloads/origin/client/OriginSetup.exe /silent
Start monitoring process.
fsync: up and running.
libGL error: glx: failed to create dri3 screen
libGL error: failed to load driver: nouveau

I also tried this ,

pacman -Rdd nvidia-utils
pacman -S nvidia-libgl
pacman -Su

but it does not help.

Thanks for help.

1 Like

The problem is, that the origin shop is installed and I can install games, but because of the failure everything rolls back.

I didn’t realize, that origin was installed, so everything is fine.

1 Like

I think a simple thing is to install Proton, this will solve many problems.