Can't install games from Lutris installers anymore

A few days ago, I decided to clean a bit the Wine runners and removed some old Wine versions in ~/.local/share/lutris/runners/wine. Kept a few old ones and the most recent. Since then, I don’t seem to be able to install games from Lutris scripts anymore.

When I click on “Install” after selecting a game in Community installers, nothing happens. When running Lutris from a terminal, I get the following error, e.g. for X-Wing Alliance which I had previously installed:

2021-12-15 13:14:46,244: No game found. Replacing with placeholder {'id': 'star-wars-x-wing-alliance', 'appid': 'star-wars-x-wing-alliance', 'name': 'STAR WARS: X-Wing Alliance', 'slug': 'star-wars-x-wing-alliance', 'service': 'lutris'}
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/lutris/gui/", line 497, in on_game_install
    game_id = service.install(db_game)
  File "/usr/lib/python3/dist-packages/lutris/services/", line 188, in install
    appid = db_game["appid"]
TypeError: 'NoneType' object is not subscriptable

With a game that I hadn’t installed previously, I don’t get the Python error, only the appid one, e.g.:

2021-12-15 13:20:23,607: No game found. Replacing with placeholder {'id': 'star-wars-x-wing-vs-tie-fighter', 'appid': 'star-wars-x-wing-vs-tie-fighter', 'name': 'STAR WARS: X-Wing vs. TIE Fighter', 'slug': 'star-wars-x-wing-vs-tie-fighter', 'service': 'lutris'}

I’m not completely sure that the issue comes from removing old Wine versions but it’s pretty likely, unless there have been changes on Lutris’ side and it’s a coincidence.

Any idea how I can fix this? Maybe redownloading old Wine runners versions but I’m not sure how.

1 Like

Ok, I’ve found where to manage the runners properly (Preferences → Runners) and reinstalled Wine 5.6.5 which is specifically set in the install script for X-Wing Alliance. It seems to have repaired the issue as I can now use the Install button, either for this game or others.

There’s still one small issue in that when I want to install XW:A I get an error message saying it can’t find the installer as soon as I click Install. I still get the interface which allows me to continue installation and select the files but I assume there’s some caching issue in my Lutris config that still refers to old runners and setup exes.

1 Like

I don’t know which version of Lutris you are on, but just try to reinstall the runners by de-selecting and selecting. It will re-download and install the runner again. You can deselect the versions again and then remove them. This should solve the cache issue.
I guess you have already figured out how to manage runners, it seems I am on a different version of Lutris. I am using Lutris and in that, I would go to Manage Runners (in my Lutris version it is below the preferences menu option and not in the preferences in Lutris settings menu) Under that Wine->Manage Versions.

Yeah, that’s what I found out (Preferences → Runners). At first I was looking in the runners options in the main interface (left column) so I thought it was not possible to manage the Wine versions properly and deleted old ones in ~/.local/share directly.

I haven’t tried yet to re-enable/re-disable all of them, just the one version that was set by X-Wing Alliance (5.6.5) and it seems to have fixed the issue.