Cant install from homepage(nothing happens)


I just installed lutris but dont seems to be able to install any game, when i press install on the homepage nothing happens, its like its not associated with lutris to open?

Please can someone help me?


I recommend running Lutris once and logging into your account (for ease of management, but probably unnecessary).

If after that install links are still not linked to your Lutris, you can try on a manual

lutris name-of-the-game


lutris warframe


lutris path-of-exile

As long as you put the same name as the game’s page on Lutris’ website, you should be able to find the appropriate script. Make sure to install Wine system-wide to prevent headache with Wine games. (<- pick your proper linux distribution before follow the steps)

Hello dan1lo_bc,

When trying what you say i get that where is no installer for the game, i tried for example mafia II.


You have to use the same code as the url. Usually, everything is lowercase and spaces are hiphens.

would be

lutris mafia-ii

Do you have wine installed in your system?