Back to the main site

Can't install battle.net

I don’t know why but today I couldn’t launch battle.net at all, it said it was running but nothing happened for almost an hour so I decided to reinstall it.
Sadly this also was not successful, whenever I try to install it and get to the Installing Blizzard App. stage I see in logs stuff like

lutris-wrapper: /home/rafii2198/.local/share/lutris/runners/wine/lutris-GE-Proton7-16-x86_64/bin/wine
Started initial process 28223 from /home/rafii2198/.local/share/lutris/runners/wine/lutris-GE-Proton7-16-x86_64/bin/wine /home/rafii2198/.cache/lutris/installer/battlenet/setup/Battle.net-Setup-enUS.exe
Start monitoring process.
fsync: up and running.
wine: RLIMIT_NICE is <= 20, unable to use setpriority safely
The application failed to start, or there is no application associated with the file. 
ShellExecuteEx Failed: File not found.

Monitored process exited.
Initial process has exited (return code: 256)
Exit with return code 256

I have no idea what is causing it. Now I know it is because of some file but I have no idea what. My speculation is that there might be a bug in that new install script but I am not sure.

1 Like

Alright the fix was quite simple I don’t know why I didn’t think of that earlier but I just manually downloaded Battle.net installer and provided that in Lutris and it worked!

False alarm. now the installer crashes mid way through. This is what logs says

lutris-wrapper: /home/rafii2198/.local/share/lutris/runners/wine/lutris-GE-Proton7-16-x86_64/bin/wine
Started initial process 12833 from /home/rafii2198/.local/share/lutris/runners/wine/lutris-GE-Proton7-16-x86_64/bin/wine /home/rafii2198/Pobrane/Battle.net-Setup.exe
Start monitoring process.
fsync: up and running.
wine: RLIMIT_NICE is <= 20, unable to use setpriority safely
<html><head><title>Object moved</title></head><body>


<h2>Object moved to <a href="http://www.blizzard.com/404">here</a>.</h2>


</body></html>


GIF89aInitial process has exited (return code: 0)
2 Likes

Olá, verifique se você tem o “lutris-GE-Proton7-16-x86_64” em “.local/share/lutris/runners/wine”

Se estivem faltando, baixe em “Release Wine-GE-Proton7-16 Released · GloriousEggroll/wine-ge-custom · GitHub” e extraia na pasta.

Espero que seja útil.

=============================================================

Hello, check if you have the “lutris-GE-Proton7-16-x86_64” in “.local/share/lutris/runners/wine”

If they are missing, download from “Release Wine-GE-Proton7-16 Released · GloriousEggroll/wine-ge-custom · GitHub” and extract into the folder.

I hope it’s helpful.