Back to the main site

Can't get controllers to work with wine


#1

Few months ago I could play with any controller perfectly in Lutris with wine-steam games with xbox controllers and sc-controller for the steam controller. But then for some reason, i don’t really know what caused this, but i can’t get any controller to work well in wine games.

Xinput games won’t get any inputs at all, and Dinput will get some but it will mess up with few seconds of use, so it’s unplayable.

I tried to get support from reddit and the discord before, but now my previous method (using dumbxinputemu) makes my game not launch at all for some reason.

I’m having this problem on both my pc (Manjaro) and my laptop (Solus). I’m using a steam controller and a official xbox360 controller, both with the same results. I’m trying to get the controllers to work mainly for a game called Rivals of Aether (has xinput and dinput modes), but I tried other games (xinput and dinput) and the same happens.

Maybe I’m just using Lutris’ controller support wrong. I tried using the x360ce and dumb xinput ticks, and writing the games’ path to the .exe, do I need to do something else? Last time I got it working, I had to download the dumbxinputemu files and place the files in the games’ folder, but that didn’t last long. I’m currently using Wine 3.0.