Can't connect Epic Games as source

Update 2: I confrm it was fixed in version 0.5.12. As for now, you can grab the beta from the GitHub page linked below.

Update: seems like something changed on Epic’s side and third party apps cannot connect anymore. The Heroic guys managed to fix it already:

Please fix this also in Lutris. Thank you.

Leaving the old post below so that others with the same issue could find this thread easier (just removing the output link, because it is not relevant anymore and I cannot post more than 2 links).

Hi. As the title says, I can’t connect Epic Games as source. After typing the two-factor code, the login window just disappears and does nothing. I have installed the latest version of Lutris a couple of days ago and Epic was OK. The problem appeared today. Tried the Flatpak and the deb from

(PPA still has the old version without Amazon). Tried renstalling the Epic launcher. Tried logout/login in the Epic launcher. Nothing helps. All other soures OK. Epic Launcher OK, just the source connection stopped working. Please help.


I am experiencing something similar. It seems I can login, but games aren’t listed . I am guessing that the API changed or something happened.

1 Like

Yep same here, everything else is fine, just Epic won’t display any games.

1 Like

I also try to ran Epic from Wine category and I cannot login on it. I got connection error message.

1 Like

same here. It was fixed on heroic but not on lutris

Anyone worked out a fix?

Fixed here already.
I tested this yesterday fix and it works.

1 Like

Sorry for necroing this thread, but i tried to use the link but in that thread, the links to the file are dead. And my install of lutris won’t list any epic store game.

Did you find any fix for this issue?
I am unable to login to the Epic store: the login window appears, and after login it hangs.
If I move it, it’s completely white, and even after 1 hour no signs of life.
I have to close the login window with the “x” on top to be able to use Lutris again