Can't click on checkboxes on Manage Wine Versions

Good day folk!

I’m new on the linux community at all, although I had some lessons on college I never really tried to get into it.

Recently I got tired of Windows and migrated to Linux and now I’m a proud user of Linux Mint 18.3 Sylvia.

I’m trying to run Guild Wars 2 with the WinePBA built in Lutris. The problem is, everytime I choose > Manage Wine Versions, to try to check the WinePBA checkbox, nothing happens, no signal, no graphical feedback, nothing…
Did I miss something?

Yeah the behavior for that window is getting reworked I believe. No ETA though. You just need to click the checkbox once and wait a couple seconds for it to start downloading.

I’ll give it a try

EDIT: Really worked. THanks!

EDIT 2: Sorry it didn’t… The download gets to 99% and then stops and nothing happens.

I had the same issue : the GUI user feedback is really bad. I thought it was broken, I even removed a wine version I used (and that is instant!) and was left with the one from my system which was bad for the game.

Really bad experience which can be fixed if only the box could be checked instantly.