Back to the main site

Can't change ulimit for Esync

Hello, I installed Lutris and I need to change my ulimit value to make Esync work so I followed this : docs/HowToEsync.md at master · lutris/docs · GitHub. But after reboot my ulimit -Hn still shows 4096. From what I could find my system is using systemd but I tried both way and it just won’t change the value. Does anyone have an idea why ?

Edit : I’m trying to launch League of Legends and without Esync my computer instantly freezes.

Yeah, that’s bollocks… I don’t know WTF, but systemd seems to override that for all processes running under it. (which is pretty much everything, it’s got the init program)

I just ended up forcing it as default in /etc/systemd/system.conf

DefaultLimitNOFILE=1048576:1048576

I’ve found that to be enough for everything. That line is probably there commented, so uncomment and edit it for your desired values of hard and soft. If you have uncommented/edited it in user.conf, comment that out again.

Personally I don’t give a toss, it’s my system (and my gaming system, at that). I also do a lot of big build jobs that work with a lot of files at once.

I don’t like limits :slight_smile:

Unfortunately this is still not doing the trick… I have values in /etc/systemd/system.conf, /etc/systemd/user.conf and /etc/security/limits.conf and my ulimit -Hn is stuck at 4096…