Back to the main site

Can't add Steam Shared Library game

I’ve been using Lutris for a while now without issues. Recently, I enabled Steam Family Sharing on my wife’s account and added one of her games to my computer (The Witness), I can see it and installed it via Steam, but I can’t see it in Lutris (nor add it like I usually do with other non-shared Steam games). Is there a setting I need to change or some other means to get shared library games to show in Lutris?

pastebin

Thanks,
Paul

Lutris does not management games from steam so if you want to see it appear on Lutris game list then you must:

Enable Local Games in Lutris Preferences → Services
Change Lutris Steam preference → location to your steam library location
Open steam → Install The Witness → Done

Then The Witness will appear in Lutris game list (Local) (without game banner / icons). All you need to do is run it once from Lutris launcher

1 Like

@bluesaka111, I wasn’t able to follow your instructions. I see the first one, but not sure where to change the steam library location (it is already set in the preferences). When I made the first change and then look at Lutris game list (local), it only shows “Steam”, not any individual games.

However, I was able to find a solution. I clicked on Lutris under Sources on the left bar and then “Community Installers” tab at the top. Selecting “The Witness” gave me several choices including “Proton”. I chose that and it did the (pseudo) install and configured the game with the correct SteamId and provided the correct name and banner. I then launched the game from that icon and it started up fine.

Thanks,
Paul

You can change where Lutris look for Steam games by clicking on the gear icon next to Steam in the Runner section.