Back to the main site

Cannot Start Game in Starcraft II

I followed the installation procedure for SC2 and it fully installed without a problem. However, in game I cannot click on any button to start any actual gameplay.

I’m brand new to Wine and Lutris (and gaming on Linux in general) and don’t even know where to start for fixing this. Any recommendations would be greatly appreciated.

Did you have any luck? I play SC2 daily. I added a couple of overrides to make DXVK behave properly, but never experienced the issue you’re having.

No luck thus far. The graphics do seem a bit off, but appears playable. It seems like the game isn’t properly connecting to servers since it seems to be constantly hung up on anything that has to do with getting data from servers. I don’t know where to look to fix this, and it seems especially bizarre because I had no issue logging in to battle.net.

It might be some kind of weird issue with the game itself, possible it’s corrupt? Also we just had the 10 year anniversary update the other night, make sure your game is up to date.

Have you tried running scan and repair?

Also for dx9 to work correctly with dxvk you need the proper windows compiler dll’s otherwise you will experience issues especially if you ever manage to run a custom game. Run winetricks from Lutris and add the ones I’ve got selected.

Sorry, I read you are new to Linux…
Right click on the game in Lutris > Winetricks > Select default wine prefix (ok) > Install a Windows dll or component (ok) > then tick the ones in my screenshot (ok). You can close winetricks once thats done.

Update: This is very bizarre.

While in the game, I navigated through some menu windows and found a bookmarked map. For some reason, SC2 had no problem downloading this map and playing it. After a game against the AI, I returned to the main game menu to find all features working properly. (I haven’t tried multiplayer yet, but I am able to get maps and play games in the normal fashion.)

I have no idea why this worked. It is possible that playing a game simply left me in the game long enough for connections to the server to get going, or downloading a map got the game working. (I’ve left the game running for 5 minutes before to see if it would help, but the game vs. AI was 10 or 15 minutes.)

At any rate, the game is working (persistently, I checked). If anyone has a similar issue, I recommend finding any map you can play on to get the game to download something.

Thank you for the replies LeJimster, I’ve been using Linux for a couple years now, but this is my first foray into gaming on Linux. I’m glad to see such an active and capable community behind it.

1 Like

Nice, glad to here you got it running.
I would still add the d3dcompilers when you get chance though. I mentioned it on the SC2 Lutris script page but nobody has picked up the change and I’m not really sure how to submit a fresh install script with those changes.

Certain custom games will crash the game without those additional dll’s. TBH, I’m surprised I’m the only person who has reported the issue. Maybe theres not that many of us Linux users playing SC2 online.

Update:
Right. I managed to copy the install the scripts for SC2 and Battle.net and add the correct d3dcompiler etc. They are called “DXVK + d3dcompiler_42 version” under the unpublished installers.
Hopefully somebody will notice and add them to the published ones as I’m not interested in maintaining any scripts.