Cannot launch WineSteam from Lutris (with error)

First off, I’m a bit of a noob with Linux, tinkering with the command line and general stuff like that so please bare with me :slight_smile:

I managed to install both Mafia 1 and Return to Castle Wolfenstien this past week with only minor issue, this morning I played both without issue only for this afternoon to not be able to play (RtCW, I haven’t tried Mafia 1)

As far as I know, I’ve not changed or edited anything so why this has happened is beyond me; I then tried to launch “Steam Wine” from within Lutris only for ‘nothing’|690x238 to happen (some sort of error, when launching in a terminal)

One odd thing I’ve noticed (I’m fairly sure it’s unrelated to the issue as to why SteamWine wont launch, but an issue none-the less, is that Return to Castle Wolfenstein has moved from the “Wine Steam” category, to the “Linux” category (despite, not actually being on Linux) oddly, I’ve tried to edit the config of RtCW to change the “runner” from Linux, to Windows Steam but cannot save the changes when I click “save”… Odd?

Anyway, if anyone can shed some light on how to fix this issue I’d be very, very grateful!

Thanks in advance,

  • Nachos.

an update; someone suggested the following which helped me launch WineSteam again;

you have misconfigured a game with the steamless_binary option, which uncovered a bug in lutris, go to ~/.config/lutris/games and search for a file containing steamless and fix it (just remove the line). That will solve the crash

However, after deleting all the files except the ones I needed for my games, Return to castle wolfenstien still doesn’t launch with the following issue;

000b:fixme:winediag:start_process Wine Staging 3.13 is a testing version containing experimental patches.
000b:fixme:winediag:start_process Please mention your exact version when filing bug reports on
wine: Bad EXE format for Z:\home\zzz\Games\return-to-castle-wolfenstein\wolfsp.exe.



Exist? Your runner may be pointing to a missing installer.

You can always try backing up your current game data (the actual game data from steam/steamapps/common/GAMENAME) and install once again with Lutris. When wineSteam is about to go to download the game, exit it, copy and paste the game on the new directory and it shall catch up (just make sure to put it under the right /prefix or /prefix64, according to your installer script).

Now if wineSteam doesn’t exist at all to try this or your games, I’d recommend first fixing winesteam. You can do that by either checking its configuration or be more aggressive about it and delete the entire runner in


Just remember that this will delete everything inside prefix and prefix64, meaning any game data that you left that (possibly mafia 1 and RtWC)

Oh hello @dan1lo_bc once again come to save my skin and pull me out of the mess!

To answer your first question, I think you might be on to something - because I do not recall pointing the installer to that path;

I’ve tried “going” to that path Z:\home\zzz\Games\return-to-castle-wolfenstein\ and can’t find it using Thunar file manager. So I think you could be correct with this. Although as to why that might be I’m unsure, I didn’t change any of the paths and left them as they were - should I attempt a reinstall and try putting the path in my ~/ folder?

WineSteam I’m fairy sure does exist on my computer, because I’m able to play Mafia1 without issue, however trying to launch RTC Wolfenstien, or (and this is the issue) attempting to change the runner from Linux (Runs native games) to Wine Steam (Runs Steam for Windows Games) gives me the error; "Steam Appid no provided".

I’ve been long overdue for a reinstall of my system and at this point I feel it might be worth just wiping it all and starting again… Really not sure what I’m doing here and I can’t help but feel I’m either being incredibly stupid or I’m out of my depth… :sweat:

  • all my best

Well, when you change from Linux to Wine Steam, you have to configure that new runner. The Wine Steam runner only asks for appid, which can be found on steam store’s page (those last numbers in the game’s page)

All wine steam installers also have appids inside them.

Z:\ is a virtual drive created by wine. When you go to wine configurations, you can check C:\ and Z:, although I’m not sure why it would search on Z. I don’t know if simply excluding Z:\ from winecfg would change anything.

1 Like

Right! Okay, that makes sense, so where exactly do I put the appid? (thanks for saying where to find them! Saves me asking you in this post lol). I’ve opened up the configure of RTCW and cannot find anywhere to put it, or am I looking in the wrong place?

I’d like to point out I was trying to delete this post/thread because I realised prior to your original reply that I think I’m talking about two different issues and don’t want to cause confusion (apologies for the messy posting etc, don’t usually use forums)

As far as I know, the “SteamWine” is fine (have just got off Mafia) the main issue now is RTCW.

I can happily make a new post (as I said I wanted to trash this one and make a more coherent one)

However a brief summery is, I can install RTC Wolfenstien without issue and indeed launch and play it, but after closing it refuses to launch again; I’ve copied what I believe is the error message (and have attempted to Google it a fair bit, but I’m honestly clueless) I’ve pasted a link and the error in the thread below (but, am more than happy to make a new ticket)

--- Common Initialization Complete ---
Opening IP socket: localhost:27960
Hostname: zzz
Started tty console (use +set ttycon 0 to disable)
/home/zzz/.cache/lutris/ line 3: 17708 Segmentation fault      (core dumped) SDL_VIDEO_FULLSCREEN_DISPLAY="off" DRI_PRIME="0" STEAM_RUNTIME="/home/zzz/.local/share/lutris/runtime/steam" LD_LIBRARY_PATH="/usr/lib:/usr/lib32:/home/zzz/.local/share/lutris/runtime/lib32:/home/zzz/.local/share/lutris/runtime/steam/i386/lib/i386-linux-gnu:/home/zzz/.local/share/lutris/runtime/steam/i386/lib:/home/zzz/.local/share/lutris/runtime/steam/i386/usr/lib/i386-linux-gnu:/home/zzz/.local/share/lutris/runtime/steam/i386/usr/lib:/home/zzz/.local/share/lutris/runtime/lib64:/home/zzz/.local/share/lutris/runtime/steam/amd64/lib/x86_64-linux-gnu:/home/zzz/.local/share/lutris/runtime/steam/amd64/lib:/home/zzz/.local/share/lutris/runtime/steam/amd64/usr/lib/x86_64-linux-gnu:/home/zzz/.local/share/lutris/runtime/steam/amd64/usr/lib:$LD_LIBRARY_PATH" "/home/zzz/Games/return-to-castle-wolfenstein/wolfsp.exe"

Once again @dan1lo_bc I’d like to thank-you for your time and help with my issues, you’re truly a saint and I cannot begin to explain how helpful I’ve found your replies.

  • All my best

I wish I could help you more, but a segmentation fault means a memory problem, and I can’t start to imagine what’s causing it, since you can play it perfectly the first time.

First things. The appid can be found on the steam page itself.

For example, this game’s appid is 9010, and that’s what you put in your wineSteam runner.

The first thing I’d look for in the file /home/zzz/.cache/lutris/ mentioned in your report. I’d look at the mentioned line 3 that’s causing trouble and see what’s going on.

Also, that file being in .cache makes me believe it’s not necessary. Is it because a “run in terminal” option is marked under System Settings? Is that necessary to run the game?

A simple test you can do is simply go into that folder and take that file from that folder and put it somewhere else. Like in your desktop for example. Try running the game and see if it works. If it does, that’s a big clue. If it doesn’t, more factor may come into play.

If it does work and you want to make a simple “hotfix” for it, I suggest making a script in your desktop or simply having a shortcut for it somewhere easy so you can take it away every time you want to play the game.

Of course, this is not a solution to the problem, but a temporary workaround.

p.s.: You can rename the thread to “Game works once, but gets broken after the first time playing” or something similar. Whatever sounds appropriate, since wineSteam seems OK