Cannot install league of legends, lzma error

Hello, I’m newbie to lutris.
I just want to install league of legends through lutris.
According to “Standard (Launch Helper) version” on, I tried to install it. But nothing happens.


I ran lutris on terminal and I tried again. I see following error messages.

2020-12-16 07:05:07,916: Initializing lutris
2020-12-16 07:05:09,967: Runtime up-to-date. Initialization complete.
2020-12-16 07:05:09,977: Lutris
2020-12-16 07:05:09,977: Running AMD Mesa driver 20.3.0 on AMD RENOIR (DRM 3.39.0, 5.9.12-050912-generic, LLVM 11.0.0) (0x1636)
2020-12-16 07:05:09,977: GPU: 1002:1636 1028:0A1E (amdgpu drivers)
2020-12-16 07:05:16,264: Lutris
2020-12-16 07:05:16,265: Running AMD Mesa driver 20.3.0 on AMD RENOIR (DRM 3.39.0, 5.9.12-050912-generic, LLVM 11.0.0) (0x1636)
2020-12-16 07:05:16,265: GPU: 1002:1636 1028:0A1E (amdgpu drivers)
2020-12-16 07:05:20,715: Runner < object at 0x7fcc28197730> needs to be installed
2020-12-16 07:05:20,721: Getting runner information for wine (version: lutris-lol-5.5-2-x86_64)
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/lutris/installer/", line 165, in launch_install
  File "/usr/lib/python3/dist-packages/lutris/installer/", line 245, in install_runners
  File "/usr/lib/python3/dist-packages/lutris/installer/", line 253, in install_runner
  File "/usr/lib/python3/dist-packages/lutris/runners/", line 388, in install
    self.download_and_extract(runner["url"], **opts)
  File "/usr/lib/python3/dist-packages/lutris/runners/", line 398, in download_and_extract
  File "/usr/lib/python3/dist-packages/lutris/gui/dialogs/", line 46, in simple_downloader
    return callback(**callback_args)
  File "/usr/lib/python3/dist-packages/lutris/runners/", line 411, in extract
    extract_archive(archive, dest, merge_single=merge_single)
  File "/usr/lib/python3/dist-packages/lutris/util/", line 132, in extract_archive
    _do_extract(path, temp_path, opener, mode, extractor)
  File "/usr/lib/python3/dist-packages/lutris/util/", line 190, in _do_extract
  File "/usr/lib/python3.8/", line 2026, in extractall
    self.extract(tarinfo, path, set_attrs=not tarinfo.isdir(),
  File "/usr/lib/python3.8/", line 2067, in extract
    self._extract_member(tarinfo, os.path.join(path,,
  File "/usr/lib/python3.8/", line 2139, in _extract_member
    self.makefile(tarinfo, targetpath)
  File "/usr/lib/python3.8/", line 2188, in makefile
    copyfileobj(source, target, tarinfo.size, ReadError, bufsize)
  File "/usr/lib/python3.8/", line 247, in copyfileobj
    buf =
  File "/usr/lib/python3.8/", line 200, in read
  File "/usr/lib/python3.8/", line 68, in readinto
    data =
  File "/usr/lib/python3.8/", line 103, in read
    data = self._decompressor.decompress(rawblock, size)
_lzma.LZMAError: Corrupt input data

I tried to download manually and extract it.
But I found error logs as follows.

xz: (stdin): Compressed data is corrupt
tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now

I doubt that the file may be corrupted.

Is there anything I can do?


My dude, I think the file is actually corrupted. I’m encountering the same issue. Attempting to decompress it with tar also fails. I also posted in the r/leagueoflinux subreddit for help. Let’s see if we can get someone to fix this :slight_smile:

1 Like

I have same issue. I really want to play league of legends

I’m South Korean and had the exactly same issue. However, as soon as I tried VPN connection (Japan, in my case), it just installed. I reckon this is a keyserver problem.

Maybe connect VPN to other regions before installation.