Back to the main site

Cannot install Battle.net (Overwatch installer)

As stated, I can’t seem to get past the Battle.net installation with the Overwatch installer. The issue is identical to the one in the Blizzard App wiki page listed here. However the whole system has 32 bit library versions installed including Vulkan and Nvidia Drivers. Here is my lutris output from an attempted install. I have gone through the DXVK wiki steps in order to install everything properly as well as attempted the listed fixes for the Battle.net app specifically.

Lutris Version: 0.5.2.1
Kernel: 5.1.12
Nvidia-Driver version: 430.26

Get some logs while trying to install it. Run lutris via the terminal.

Also, your deps from the repositories you have may be out of date, as the current wine runner needs GLIBC 2.27 . msvcrt.dll.so from within the current runner complains about not having it. MX Linux and Probably Debian 9 don’t have this package in the stable repos yet.

If you can’t get a newer build, try changing to TKG 4.1 and manually run the battle.net installer via run EXE within wine prefix button after the instance has been made by the install script.

My logs are in a pastebin link in the original post. Here it is again, https://pastebin.com/V2ZBmxsS
Unless I am misunderstanding what you are asking for. That is a log of launching lutris and attempting an install from the script until it fails.
My glibc version is 2.29.
I will attempt to run the battle.net installer with tkg-4.1 and report back.

Update: running with tkg-4.1 got to the sign in screen once, but hung on the actual connection. After that it seems to be having the same behavior as before. On a whim I used the proton-4.2 wine runner from my steam install and that worked perfectly for installing Battle.net. It also installed Overwatch fine, but upon running the game crashed out. I have tried a number of other versions of wine after the install and as of yet have had no luck.

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

Looks to me that something’s out of wack with either your nvidia drivers, and/or mesa.

Would also help to know what distro you’re on.

Just to be sure, did you follow the deps guides here?

https://github.com/lutris/lutris/wiki/Wine-Dependencies
https://github.com/lutris/lutris/wiki/Game:-Blizzard-App
https://github.com/lutris/lutris/wiki/Installing-drivers

Oh Sorry, running Gentoo, which complicates things a bit. I thought I had put that in the initial post but obviously I did not.
mesa version: 18.3
I went through the guides, but I had to go dependency hunting a bit because gentoo dependencies are not listed. I figured it was a driver issue as well, but am not sure what libraries Wine Battle.net is expecting, so was not sure what else to look for. Being gentoo it could be a compilation flag for a specific library which is missing.

For anyone with a similar issue running Gentoo, for some reason the OpenGL libraries do not seem to be selected properly using eselect. Symlinking 64 and 32 bit libGL.so.1 to the appropriate nvidia path ln -s /usr/libXX/opengl/nvidia/lib/libGL.so.1 /usr/libXX/libGL.so.1 fixed the problem for me. However that seems like a hack of a fix. I will need to see why eselect opengl set nvidia does not seem to do what it should.

Did you manage to fix it just by symlinking it? :frowning: I did it but my installation still won’t continue. I’m on gentoo too and just can’t get any bnet game to run because of this.

https://pastebin.com/UKCijq1U