Cannot Install any Game From GOG [Errno 21 Is a Directory]

Recently upgraded my lutris install to the latest git version (through the AUR). I’m unable to install any games now with an error of “Error 21: Is a dirctory: $home/.cache/installer/$gamename”, only with my actual game name and home folder. Tried it again with debug from the terminal (same result), but here is the debug info:

I’ve tried this with several games from GOG and every one I tried does this. Here’s my systeminfo from Lutris:

OS: Arch Linux rolling n/a
Arch: x86_64
Kernel: 6.3.1-eupnea
Desktop: KDE
Display Server: wayland

Vendor: GenuineIntel
Model: Intel(R) Celeron(R) N4000 CPU @ 1.10GHz
Physical cores: 2
Logical cores: 2

RAM: 3.7 GB
Swap: 6.8 GB

Vendor: Intel
OpenGL Renderer: Mesa Intel(R) UHD Graphics 600 (GLK 2)
OpenGL Version: 4.6 (Compatibility Profile) Mesa 23.1.5
OpenGL Core: 4.6 (Core Profile) Mesa 23.1.5
OpenGL ES: OpenGL ES 3.2 Mesa 23.1.5
Vulkan Version: 1.3.255
Vulkan Drivers: Intel(R) UHD Graphics 600 (GLK 2) (1.3.246)

Any help would be appreciated. Thanks.


You must change your cache’s folder like this :

And it will be good.

1 Like

I’m having the same issue. What do I need to change the cache folder TO?

Thanks in advance!

I was just having this problem installing Cyberpunk from GOG. In my case lutris had made the directory .cache/lutris/installer/cyberpunk-2077/gog but was complaining that cyberpunk-2077 was a directory. After going in and setting the cache folder manually to .cache/lutris/installer it began properly downloading to the directory the installer tried to make.

Thank you!