Cannot install any game/app through Lutris

I tried to install Ubisoft Connect and Watch Dogs (1) through Lutris, with no luck

On both Fedora and PopOS, Through RPM-Ostree, APT, Flatpak, nothing changes the fact that it just won’t work

Currently I’m using lastest PopOS, installed Lutris through APT, everything is up to date, i have up to date GPU Drivers, but every time i try to install anything through Lutris, i get Error 512, 256, errors that my wine doesn’t support ESync and FSync, which it does support, and other nonsense, what’s wrong with Lutris??

I recently tried installing Epic Games Store (on my PopOs system) which always gave me the 256 error when installing Arial font. I’ve tried many different solutions but couldn’t get it to work.

A few days later I was thinking about switching to Fedora (was on PopOs for a long time now and was thinking about switching for a while) which made me install it on my laptop to test out all the nvidia driver installation stuff.
After I installed and set up everything I wanted to try out all the most important software to me which includes lutris. I experienced the exact same behaviour on my laptop. I was not able to install anything on lutris. It’d always crash with some random error code (but mostly 256 while installing fonts). I tried it with manual installations of wine and without and it basically only made it worse.
I finally made the flatpak version kinda work (not sure yet if its fully functional).

Before that I had NixOS on my laptop (also for testing purposes) and I experienced the same issue there. But at that point I was sure it was my fault cause I didn’t know how to use NixOS correctly