C&C Generals won't launch in lutris

First time trying to use wine.
Trying to get C&C Generals and C&C Zero Hour to run.
Tried lutris Nothing launches.
Installed wine-stageing, still nothing

Using Opensuse leap 15.4
wine-staging 7.19

Not sure if it is me or the game. But none of the C&C games from the Decade box set will run.
I have read many pages from winehq and watched many videos.

Can’t anyone help me get this working.

Tried running lutris with -d. here is the result.
Pastebin - Lutris Results

1 Like

I have issues with this game too. One of my favourite RTS games of all time. For me if I run the Origin version I can get it to launch but it crashes when trying to start a Skirmish with a C++ runtime error. Using either my retail copy doesnt even launch like you experience. This game was always been difficult to get working even on Windows in my experience.

I managed to find a couple of videos that helped me greatly to fix my issues.
I now have Red Alert 2 and Generals + Zero Hour working, but i am still looking for a fix for RA2 as the ingame menus are not visible, so i am just guessing.

C&C Installs
Fixes Video