Bugsplat error when start game League of Legends


When I choose my champion and the game starts, the Bugsplat screen appears and the game crashes.

Here is the log:
League of Legends caused ACCESS_VIOLATION in module League of Legends

Read from location 00000000 caused an access violation.

User Information:
    User Name: joao
    Computer Name: JoaoMint

OS Info:
    Windows XP Service Pack 3 Professional, x64

System Information:
    4 processor(s), type 586.
    58% of memory in use.
    5849M total physical memory.
    2429M free physical memory.
    8709M total paging file.
    5105M free paging file.
    4095M total virtual memory.
    4095M free virtual memory.

Process Memory:
    1264M free.
    2445M reserved.
     386M commited.
    Largest free block is 1207M.

    PageFaultCount: 0
    PeakWorkingSetSize: 276M
    WorkingSetSize: 274M
    QuotaPeakPagedPoolUsage: 0M
    QuotaPagedPoolUsage: 0M
    QuotaPeakNonPagedPoolUsage: 0M
    QuotaNonPagedPoolUsage: 0M
    PagefileUsage: 220M
    PeakPagefileUsage: 220M
    PrivateUsage: 0M

Process Info:
    ThreadCount: 28

I’m using Linux Mint 18.3, installed today, with the most recent Lutris and the DX9 Script, installed today too.

Can you help me?

I run it daily on Manjaro 64 bit with an AMD 8350 and GTX 970, runs perfect. No idea what’s wrong with this one.

Try reinstalling with default location that the installer gives you. Don’t move destinations and just press next. If you did that already, it might be that you ran out of ram. I looked up the error code and some steam users seems to have that problem.

Google it, I might have missed something.

edit: I forgot, try deleting the config file looks like another guys is getting r3d problems with it so that might be it.

I found it in a forum and it worked for me https://forum.br.leagueoflegends.com/t5/Suporte/Tutorial-de-Instalação-do-LOL-no-LINUX-Mint-19-x-e-Ubuntu-18-04/td-p/428117.

Since the 9.10 patch, the game doesn’t works with wine tkg 4.6 or wine staging 4.8. (https://bugs.winehq.org/show_bug.cgi?id=47198).

Must be noticed in the game description until the needed bug correction.