Blizzard stuck when updating

Hello everyone!,

I’ve been having problems when I try to update Heroes of the Storm any game, it gets stuck (0 B/s) every time when the download is running missing exactly 70.66 MB, I’m pretty new at wine and Lutris, can anyone help me out to debug this?, the game installed and ran flawlessly the first time it installed, the problem only appears when updating.

I’ve also tried deleting the folder from ProgramData as mentioned in the Blizzard App wiki page but I think that’s for the app related updates only.

Running the game with lutris -d doesn’t show anything that seems related, it ignores the agent.exe which is the actual thing that’s doing the update.

OS: Linux Mint 19 Tara
Wine: pba-firerat-3.11-x86_64 but also tried with WineHQ/System/Default 3.13 Staging

Any ideas?, cheers,
And thanks for reading!

Had it yesterday, that I needed to update something. I also tried deleting etc…

In the end I just waited, took 5 minutes before it to start. Perhaps too many people are updating atm with almost all games having huge updates right now.

I also had a similar issue. Rebooted and it started immediately.
Which version of DXVK are you running? I had issues updating on anything but 0.54 or 0.64.

Hey guys, thanks for the reply,

I thought the same so I left it (more than 13 hours) over night but nothing happened, I’ve been struggling for a couple days now, also the installs died now too.

I’m not sure about this, I’ve enabled the check for DXVK, I’m using Nvidia, my driver version is 390.77 and I’m actually using 0.52, changed the versions, rebooted and still no luck.

I know something weird is going on with Blizzard App, but I have no clue what it is. There are some things people have tried as you can see on the Winehq page, but nothing usefull yet.

Indeed, I’m gonna keep trying stuff out and update if anything comes up.

Can you try esync-3.13? staging-3.13 if that doesn’t work.

Hey Dox,

Sorry for the late reply, just finished trying both, deleted bnet program data folder just in case, but sadly no changes, on both versions the download just sits there with 0 B/s

I don’t get it then. I can’t reproduce the issue here, and don’t have it myself. Lets hope someone figures it out.

Linux Mint 19 is Ubuntu 18.04 based right?

Really weird indeed, and yeah, it’s a 18.04 base.

I pretty much gave up at this point, I made a Win10 VM and copied and updated the client over there, one thing I noticed is that at the point when it get’s stuck, it actually stops downloading and Agent.exe prompts for admin rights, even though the client folder was in My Documents.

Another thing is that running using esync actually allowed the Bnet client to update itself, so it’s something.

That sounds wierd, but that could point to a permission error.

now the client needs wine-staging 3.13 to work
if you are lucky to find the binaries for your distribution in the “WineHQ Binary Packages” section
or you will have to compile yourself with the staging patches that are here

Lutris has Staging 3.13 aswell. Are you confirming that setting it to Staging 3.13 is the solution?

Can others that have this issue try it? Just like I asked a few posts before? :slight_smile:

Where you experiencing the same freeze when updating/installing?

And yes, as @Dox mentions you can add other versions from the Lutris runner configuration, search Wine and in the manage versions (among this words, can’t remember atm) just click the one you want to add (it may take a while before seeing the progress bar)

Sadly as I mentioned some posts ago this didn’t work for me

+1 if that’s the case we can conclude that it’s an isolated error on my side.

No, I have people on discord just saying that deleting the folder AppData/ still is only way to fix it. There is something just wrong there. Might take a few tries it seems.

I think this issue isn’t wine specific. I had this on my lutris install and had to fiddle around with deleting folders and such. Not really sure what fixed it but finally it started updating.

Then I logged onto my MacBook, and got the exact same issue under macOS. Since the folder structure is different on mac, there was no real folders to delete. I tried a ton of things, including reinstalling the app, different internet connections and so on, but in the end I just let it sit at “Downloading” for like 20 minutes and after that it just suddenly succeeded with the download. I think there was a bug in the client, so hopefully once it updates it won’t happen again (I haven’t gotten this issue since, on either Wine or the mac).

Yeah, I think it is just a matter of waiting. The servers from blizzard always get swamped at the start of an expansion in WoW

But, try esync-3.14 / staging-3.14

Finally download update or game work with esync-3.14
esync-3.13 --> OK
3.14-staging --> KO
3.13 (staging, vanilla etc…) --> KO

Thx for confirming. If anyone else has success, please post.