Blizzard agent went to sleep error

Everytime i try to play Wow / Hearthstone i get the following error: “Blizzard agent went to sleep”.
This began yesterday after the maintenance downtime.

I am able to start Launcher fine when running it directly from Wine but not from Lutris.

Anyone else experiencing the same error?

I just played Hearthstone with the out-of-the-box installer. The only modification was changing PBA_DISABLE to 1 to properly enable DXVK.

Yeah, same here. Have PBA_DISABLE set to 1. I was working yesterday and I have not changed any settings since.
Seems like I just have to try to reinstall and try again.

I had it aswell, I just followed the link blizz gives you and fixed it. Not everything is linux related folks.

Fix is in the 3) option in the above link, repeated here since I know some of you have attention spans of a shrimp and reading 3 lines might be 2 much:

However this link contains more then 3 lines, and the real fix part is in line 3 aswell…oh well.


I tried deleting C:/ProgramData/ according to that link, which kind of worked. I could see the list of games, but for the first minute or so I got a popup complaining about that error every 5 seconds. Eventually it stopped. Deleting that directory causes to forget where all your games are installed, so I tried locating WoW. It’s been stuck “checking…” for around 10 minutes now. It appears the process is spinning at around 90% cpu usage but no IO activity, so I’m uncertain it’s ever going to finish. Additionally, if I close and reopen it, the original error is back and I have to delete the folder again.


Those links are dead. @Dox couldn’t you have just copied and pasted the solution here? That might have been more helpful.
Correction, I just tried it again and it worked. Entire process here:


  1. Close Blizzard processes.
    1. Press Ctrl + Shift + Esc to bring up the Task Manager.
    2. Click the Processes tab.
    3. Select all Agent, Blizzard, and game processes, and click End Process .
  2. Navigate to the folder containing the directory:
    1. Press Windows key + R to open the Run dialogue.
    2. Type *C:\ProgramData* into the Open field and press Enter :
  3. Delete the folder.
  4. Run the Blizzard desktop app and update the game to see if the issue persists.

If the error persists after you try these steps, another program may be causing the problem. Restart your computer and delete the folder one more time.

Note : The above steps may cause the application to forget game install locations. If your games can’t be found, you will see Install on the game tab instead of Play . To find your installation, click Locate this game or run the game launcher.