Back to the main site

Battlenet turning monitor off, not reacting to entire screen. (Was Really Weird Problem...)


#1

(Note: I’m still a new user, can only put two links in a post, so all mentions of battle.net will be written as battlenet.)

TLDR: After trying to use the script on this site to install starcraft, launching battlenet now turns off my second monitor, and games launched from that battlenet don’t know of the existence of the second monitor even tho I turn it back on before launching a game. WTF?

Long story:
Ubuntu 17.04, Lutris 0.4.14

I decided I wanted Starcraft stuff because of the blizz promotion this month, and previous ones I’ve participated in. I tried to go through the battlenet desktop app, because that has worked for me before, but all it did was bring me to the blizzard Starcraft Remastered site, which wanted me to have Starcraft installed first. I DL’ed the installer, but when I right-clicked and chose ‘wine installer’ to run it, nothing happened. (Yes, I checked using ps, nothing was happening, nothing wine was running.) So I found the Starcraft installer on this site, and clicked ‘install’. It seemed to be going ok, and I got bored (first mistake?) and tried to launch the Battlenet that was already installed in my Lutris window. This killed both, which I wasn’t surprised about, but I had seen a tickbox for ‘let two battlenet windows run at the same time’ so I found it and ticked it (second mistake?) and started Starcraft install again, which seemed to pick up from where it crashed, which was encouraging. I started the Battlenet from inside lutris, which killed the battlenet installing again, but I ticked that version and then they both ran. But when I launched the second one, my Monitor 2 turned off. Which was weird. I poked around and turned it on again by using my NVIDIA controller to change the ‘resolution’ from ‘off’ to ‘auto’ (which is how I usually have it). I launched WoW, which showed up on my monitor 1 like it always does despite having it set to launch on monitor 2. I moved it over to monitor 2, and while the mouse was the correct mouse when over that window, none of the buttons worked. Not enter world, not changing which toon, not menu/system/addons - nothing. Put it back on monitor 1, and everything worked fine. Opened the system menu and there was no ‘monitor 2’ in the dropdown.

Eventually the Starcraft finished installing, and I changed all the tickyboxes back to not allowing two instances of battlenet, But launching battlenet still turns off monitor 2, and still won’t see it in the wow system menu. Setting the monitors in the system so that the one I want the game on is Monitor 1 doesn’t work, it still turns off the same monitor and puts everything on the other. I have Monitor 2 (the larger of the two) sitting in front of me, and monitor 1 off to one side, because I want all the random pop up things to show up on the one I’m not trying to play a game on, so I can see it easier.

I haven’t launched starcraft yet; I have rebooted the entire computer between many of these steps. (Until I figured out to go into the nvidia settings console, that’s how I was getting the second monitor back.) I have no idea what I did, or how to fix this. All useful suggestions welcome. All silly ones too, as stress relief. :smiley:

ETA: Situation at the moment, about 2 hours later

I’ve set my display settings to have the larger monitor be #1 and the smaller #2. When I launch battlenet, it still turns off the larger monitor, which moves everything to the smaller monitor, and when I go into display settings again, it’s set the smaller one to #1. So I reset that, and get the larger one to #1 again, while battlenet is running. I launched wow, and it came up as the size of the smaller monitor, and the mouse wouldn’t leave the window. I had to alt-tab out a couple times before the mouse would move off the wow window, but it didn’t change from the wow ‘hand’. Ok, reboot. Same sequence of events, except this time wow came up the correct size for the larger monitor. However, the mouse wouldn’t register on the right third of the screen - if I clicked, it would activate something in the middle. Alt-tabbing worked fine, I could get the mouse back. If I moved the wow window all the way left, I could activate things further on the right of the wow window - so it looks like, no matter what resolution or size the window is, the mouse is still only seeing the smaller-monitor’s worth of the screen.

Next, I tried launching Diablo, which launched fullscreen. I sat through the initial reaper of souls starting cinematic (which sometimes the machine decides I haven’t seen), at something like 10fps. serious stutter and lag in the visual, tho the audio was fine. Same lag happening on the initial screen, as I went through the options list and lowered all the graphics (which had run fine, last month). But again, even tho it launched fullscreen, the mouse wouldn’t work on the right third of the game window - it would move there, but when I clicked the sprite would jump to somewhere closer to the 1/3 mark on the monitor going left to right, tho the same height up/down.

I want to stress that NOTHING ELSE is odd. Other than the blizz games, I can move windows anywhere, I can click functionally anywhere on the screen, everything else appears to be working. The smaller monitor is an Acer 19inch 1280x1024 resolution, and the larger is a Dell 24" 1920x1080 resolution. The machine is a DIY upgraded in parts; I can probably find out what the pieces are if I had to, but advice on doing so short of taking the machine apart to stare at the pieces would be needed.


#2

Ok. I may have figured it out, but I’m not sure, and I’d like for someone else to check me on it.

Apparently, as I was poking around at things, I changed the “Switch Resolution To” dropdown to the resolution of my smaller monitor. I changed that back to ‘keep current’ and rebooted, and launching battlenet did not turn off my larger monitor. When I launched wow it launched to a reasonable size on my larger monitor (currently the primary monitor) and I can use the mouse all over the screen, and have no problem moving the mouse off the wow window.

If this is the culprit, I don’t think it’s working as intended… the ‘turning a monitor off’ is not something I would have expected at all.


#3

You most likely used your scrollwheel to browse through the settings, it went over the dropdown menu of the resolution settings and you changed it. I has happened to me aswell by mistake. You can set it back to default (which does nothing) by click the <[x] button on the right of the option.

It is indeed a bad idea to install another Blizzard game while you already have Blizzard App running.

I tend to switch the games to use “Windowed (Fullscreen)”, then they never mess with your resolution either.

As for Diablo, you forgot to check: Launch 32 bit. Then you can go to the highest settings again.


#4

I don’t have a mouse scroll wheel. I have an old trackmouse (logitech track ball, old symmetrical style).

Blizzard is complaining that running 32 bit for wow is soon to be completly unsupported so I wanted to go to 64 bit for all, cause if they do it for wow they’re likely to do it for other games too.