Battlenet not working with the new Lutris 0.5.5 version!


Since I updated Lutris this afternoon to the new version with apt to 0.5.5, battlenet doesn’t want to launch. More precisely, the login page lauches, I put in my credentials, it sends a request on the battlenet authentificator, I accept it, it makes the login page disappear (just like if it succeded to login), but even if I wait, nothing shows up.
I tried reinstalling Ubuntu 19.10, then winehq-stable with the wine instructions ( and instructions from the site to install Lutris. The only thing that does not turned well was when I installed sc2 (my final goal, for that I downloaded battlenet with the sc2 install on lutris website), I manually close the login page, because Lutris doesn’t do it.
Then I’m in the situation I already mentioned.

Please help, gaming is important ;D
Thanks !

PS: Lutris 0.5.4 was working like a charm. Nostalgia…

Lutris -d : (Only the end, 'cause new users can’t put links …)

Initial process has started with pid 13897
Game is considered started.
esync: up and running.
Initial process has exited.

You can and you did (twice, actually). There’s a limit on how many links can be in a post; so I’d suggest avoiding writing URLs when you mean to merely mention a website (write its name instead).

Ok, but there wasn’t in lutris -d return, but it said so…
Anyway, if want another line, make me know ;D

Ok then, I managed to find the 0.5.4 version on the download page, and Battlenet (and SC2) work perfectly. Please fix.

Where did you find the 0.5.4 version of Lutris? I am having the same problem since updating to 0.5.5 and want to revert.

The tarball option still points to the old version. But actually they’ve kept all builds since v0.2.7 hosted there, so it’ll be available even after they update the link.

Thanks a bunch! Any chance you can explain how to install it? I’m still a total noob with Ubuntu.

Tarballs aren’t packages used by package managers (except for dists like Gentoo which don’t have a custom package format); they are standalone releases. Just unpack it somewhere and run from there (more details can be found in INSTALL.rst; but take note it warns against running manually). If you want to override the application menu link, you can copy the one from share/applications (or existing one, from /usr/share/applications) into ~/.local/share/applications and change Exec entry to use the binary from unpacked version rather than the globally-installed one.

I can’t even install anymore with the new version.

1 Like

Hello world, first post on this forum.

I also have this issue. I am using Manjaro KDE, non-free nvidia drivers, newest non-rc kernel, and all packages from the stable branch. When installing a program using, the proper behavior is for the script to launch the blizzard battle dot net installer, and then automatically close the battle dot net installer once it finishes and reaches the login page. However, as of Lutris 5.5-1, the installer does not close automatically, and if you manually close it the Lutris script will hang.

Downgrading to 5.4 using the following method solved my problems, though I don’t suggest it unless you can’t find another fix or lutris doesn’t fix this soon. This guide page is for Manjaro, which uses pacman package manager, so I don’t know how other distros will behave. Use at your own risk.

Same here.

For the last couple of days I had trouble logging in to World of Warcraft Classic (got errors no connection possible). But after some tries I somehow got in. It even seems as if Lutris kills my internet connection for 1-2 minutes, because I can’t access any web page after trying to log into

Since last night I only get to the login screen but from there nothing happens anymore. Still killing my internet connection for a short time, though.

Do I need to set this Lutris up the way my broken one is? Do I have to reinstall my games?

All the user-specific data (config, runners, game links) is stored in your $HOME directory, so different versions of the same program usually just use the same config files not even knowing they were created by a different version. The only cases where it doesn’t happen is when either the app config paths change between versions (a very unlikely occurrence IMO, usually happens when the app is rewritten completely and the previous location is deemed too ‘outdated’), or when the app changes the file format enough to consider those made by the other version invalid (doesn’t happen that all often).

If you’re not sure, you can back up Lutris config files before trying to run a different version. Their locations are: ~/.config/lutris (Lutris settings, and configs for runners and games), ~/.cache/lutris (downloads, login tokens, and temporary files), ~/.local/share/lutris (game banners, libraries, runner files, and the database of installed games).

Looks like it is happening for Starcraft too, I replied to this user on the Github that we have a problem too. i am on Arch 5.5.13 Kernel and Gnome 3.36

1 Like

Happy to know I’m not the only one with this issue. I hope it gets resolved soon

1 Like

Okay looks like it is working a little again, when you come to the state of the log-in window not closing automatically just close it and cancel the installation, press play in Lutris. Just did it right now with a fresh installation of Lutris.

This didn’t work for me with Starcraft 2. Tried the previous version of Lutris and got an Ubuntu login loop. Time for Windows?

That, or downgrade, or wait for the next Lutris release.

Lutris devs know this issue, they are working on it and it will be resolved in the next version.
If you don’t want to wait use last git version or previous Lutris stable version.

Hello there!

Since I also use Manjaro KDE, maybe you might help me. I installed and hearthstone without any issues. But when I try to launch the game, I can see hearthstone logo, after a couple of seconds it does not launch and closes itself back to app without any errors. Do you have any idea about this?

Does anyone can play any blizzard games on lutris? I have seen some rumors on the net that Blizzard banned linux players from their servers who uses wine. Can anyone conifrm that if it is true or not?

Thanks a lot.

I don’t needed to downgrade, just installed Bnet and it works now in 0.5.5. This is how I did it:

The login window doesn’t close automatically so just close it by yourself, wait untill the WoW or bnet icon in Lutris appears and hit Play. Works for me.