BattleNet installer issues are caused by the default Lutris runner - How can I run an install script with a custom runner?


Lately I’ve been having some issues with the default lutris-7.2-2 wine runner (see proof in my post below showcasing the BattleNet installer)
Several install scripts are unable to complete with this runner.


When I click the “+” icon on the top left corner and select “Install from a local install script”, I want to be able to use a custom Lutris runner / Wine version (lutris-GE-Proton7-29) to run the script instead of the default “lutris-7.2-2” Wine runner. Is that possible?

I have been able to circumvent these issues by using a different wine runner (lutris-GE-Proton7-29) by doing the following:

  1. Download the Windows installer exe file from the main website of the game
  2. Select the “+” icon in the top left
  3. Select “Add locally installed game”
  4. Select “Wine (Runs Windows games)” as the “Runner” in the “Game info” tab
  5. Select the Windows installer exe file as the “Executable” in the “Game options” tab
  6. Select “lutris-GE-Proton7-29” as the “Wine version” in the “Runner options” tab
  7. Click the “Save” button

After completing the installation options, I select the newly installed game launcher exe file as the “Executable” in the “Game options” tab.

This is a workable solution, but this means I have to manually check what custom steps some installer scripts (like overwatch 2) are doing besides the standard installation process and perform them by hand.

Is there any way for me to download a lutris installer script (JSON) file and running it with a custom wine version like lutris-GE-Proton7-29?

Currently I can only do the following:

  1. Download the lutris installer script from the lutris page (e.g.
  2. Select the “+” icon in the top left
  3. Select the “Install from local script” option
  4. Select the download json installer script (e.g. overwatch-2-standard.json)
  5. Click the install button
  6. Click the other install button

Lutris then starts downloading the “lutris-wine-7.2-2” Wine version which I explicitly uninstalled because the script doesn’t work with that version.

I want to run the script with “lutris-GE-Proton7-29” that does work with the default Windows install exe file of

Is there a way for me to:

a) Select a specific Wine version that I want to use to run a locally download Lutris script (JSON/YAML)?
b) Select the default Wine version that I want to use for all my Lutris actions e.g. install from script, install from local exe, etc.

Could you help me figure this out?

Install Bottles
Use create a new gaming bottle
Use the installer in bottles to install
don’t download the game just yet
You can now move this to your user name/Games folder. On Mint for example, it is in /home/user name/.var/app/com.usebottles.bottles/data/bottles/bolttles/World-of-Warcraft.
In Lutris, click + add local game etc and on Game Options point the executable to the in the folders you moved over. Set your runner, turn off esunc and fsync, add any other runner and system options and press launch. May not start first time as it resyncs with your new runner, but try a couple more times and it should start and you can log in to download your game.
Yes I just tried this now - not elegant, but it is a work around if no one can come up with a script.
Though will confess I am curious as to what issues you are encountering with loading the - most of the time this occurs because you are missing the 32 bit Mesa or nvidia libraries - check the Wiki in Git on the dependencies and perhaps post some images of where you are getting to with the install that suggests the Lutris runner is the issue.

Thank you so much for responding!
I’ll give Bottles a try, but on a first glance it seems that it does the same thing as my current workaround.

I’m able to install with the custom Lutris runner but then I don’t have the benefit of using the provided Lutris scripts that define extra steps like DXKV setup, etc.

I’ll keep you posted on my experience with Bottles and will provided the necessary info on the default Lutris runner vs. the Glorious Eggroll version.

And again, thank you for your reponse!

I believe the lutris-7.2-2 wine version is causing issues for several installer scripts.
Initially, I created this post with a lot of screenshots per steps, but since I’m a new user I’m limited to one.
My apologies.


I can install Battle net with the lutris-GE-Proton7-29 runner but not with default lutris-7.2-2 runner.
See below for the proof.

I’m not looking for a fix of the lutris-7.2-2 runner but a (new?) feature that allows me to run Lutris install scripts (launched from the Lutris website or a locally download JSON or YAML script config file) with a custom runner, not the default lutris-7.2-2 runner.

Is that possible? Should this be a new feature so people aren’t obligated to run install scripts with a borked lutris runner?

Attempt 1: Using the default install script

  1. Go to the Battle net Lutris page
  2. Click on the “Install” button
  3. The link opens a Lutris instance
  4. Click the “Install” button
  5. Click the next “Install” button
  6. Lutris starts downloading the lutris-7.2-2 wine version which I specifically uninstalled
  7. Click continue in the installer window
  8. After some time, the Battle net installer window pops up
  9. Select “English” and wait
  10. After some time, the following issue pops up:

**Attempt 2: Using the Battle net executable file from the original website with lutris-7.2-2"

  1. Download the file from App – Blizzard Entertainment
  2. Click on the “+” icon in the top left of the Lutris main screen
  3. Select the “Add locally installed game” option
  4. Name it “” with runner “Wine (Runs Windows games)”
  5. Select the “” file as the executable
  6. Select “lutris-7.2-2…” as the Wine version
  7. Press “Save” and open the newly configured “game” with the “Play” button
  8. The process crashes after a while
  9. The following logs are shown (a known error that’s often contributed to firewalls, VPN’s and filtering DNS services, which have all been thoroughly double checked and can not be part of the issue)
<html><head><title>Object moved</title></head><body>

<h2>Object moved to <a href="">here</a>.</h2>


Attempt 3: Using the Battle net executable file from the original website with lutris-GE-Proton7-29

Repeat steps 1 through 6 of attempt 2 with the following changes:

  • In step 4. name it “” instead of “”
  • In step 6. select the “lutris-GE-Proton7…” wine version instead of the “lutris-7.2.-2…” wine version
  1. The login screen appears as expected

Which game do you want to install? If it is Overwatch, there is a guide posted in other threads on here on getting it running, any other game, use the World of Warcraft install script.

It’s not really a game specific question.
I was mainly using the BattleNet issues to point out a missing feature in Lutris: a way to specifiy which runner / wine version you want to use to run a Lutris script.

Today, I’ve found that you can just download the Lutris configuration file (JSON / YAML) and edit the wine.version property to the version you want to use.

Still, I think it would be nice to have a UI option that makes it easier to troubleshoot faulty Lutris scripts.

Glad that works - hopefully someone takes note of your suggestion…