Battlefield 4 through EA app refuses to start in virtual desktop mode

I’ve been having difficulties getting Battlefield 4 to run in a virtual desktop through the EA app. The reason I want to run it through a virtual desktop is that my mouse refuses to stay within the same window when I run the game normally, and so when I shoot it switches the active window.

When I enable virtual desktop mode, the EA app should start but it just doesn’t. I’ve also tried using Gamescope as an alternative, but I get nothing but a black screen when I try to start the app.

lutris -d
lutris --submit-issue

Game log:

tlutris-wrapper: Battlefield 4™
Started initial process 14981 from /home/lovkal/.local/share/lutris/runners/wine/wine-ge-8-26-x86_64/bin/wine /home/lovkal/Games/ea-app/drive_c/Program Files/Electronic Arts/EA Desktop/EA Desktop/EADesktop.exe origin2://game/launch?offerIds=1010269&autoDownload=1
Start monitoring process.
fsync: up and running.
wine: RLIMIT_NICE is <= 20, unable to use setpriority safely
ntlm_auth: /home/lovkal/.local/share/lutris/runtime/Ubuntu-18.04-x86_64/ no version information available (required by /nix/store/f18n13k3fm7cqpqnaqf8jv282h9i0q36-samba-4.19.2/lib/samba/
ntlm_auth: /home/lovkal/.local/share/lutris/runtime/Ubuntu-18.04-x86_64/ no version information available (required by /nix/store/f18n13k3fm7cqpqnaqf8jv282h9i0q36-samba-4.19.2/lib/samba/
createDummyGLContext: ChoosePixelFormat failed. (Class does not exist.)
Unrecognized OpenGL version
Unrecognized OpenGL version
Initial process has exited (return code: 17152)
Monitored process exited.
Exit with return code 17152

From one of the logs, what I can gather is that I seem to be missing the module? This isn’t a package I can find with my distro however…

Any help would be appreciated, thanks!!

If you are running lutris 0.5.16, you will see on the runner options tab a note saying that Wine virtual desktop is no longer supported.
To lock your mouse, highlight the game in lutris, click the up arrow next to the wine glass at the bottom and select Wine configuration. On the graphics tab, enable the top option to capture the mouse in full-screen windows and then press Ok. Make sure you have full screen enabled in game.
Last resort which MAY work, is just for BF4 to set wine version to 7.2-2 (add from wine manager on the left hand pane under runners).

1 Like

It was that easy, huh. Thanks a lot!