Back to the main site

Battlefield 4 on lutris


#1

I would really appreciate if someone could make a proper guide to install Battlefield 4 from scratch with all the necessary settings, all the way from the beginning

I cant get it to work, and I am tired of getting just bits and pieces from here and there good willing people suggesting try this try that and so on.

I would like someone to explain exactly what is needed and what is not

including wine version, lutris version, required nvidia driver version, dxvk version, if any and all of these are necessary and so on.

Playing around with random settings when I dont even know what these things are for or if they are necessary, is not productive.

I would expect at least one proper guide to be available on this site that explains it all.

Thanks.


#2

Dude it’s complicated !!!
Here I use version 396.45 NVidia
0.54 dxvk
Wine 3.12-esync
For me it’s turning up well considering my FX4300
Does yours at least open the Origin lance?


#3

I have gotten as far as running origin, it installing bf4 and I have managed to run bf4, but at the first main screen the moment I click anywhere it crashes…

People have told me not to use latest nvidia because Im a nuub and I maybe not able to revert it if things turn bad.


#4

This is not a problem with the nvidia drivers, to tell you the truth I use any nvidia version from 390.77 to 396.45 and Aki for me makes no difference!
You could say what error message you give when closing the game, maybe I’ve already gone through it and can help you !!


#5

yep it did it again, and gives no warning or error, the minimal animations at the first screen do initially work (like highlighting button when hovering over them with the cursor) when I click it hangs.

Where can I see additional error messages?

And it takes really long time to load so playing around with settings is extremely slow.

btw the cpu runs at full even after the crash.

wine staging 3.11 x86_64
DXVK disabled

nvidia 384.130

then we have tons of other settings which I dont know what they do…


#6

ok so now I figured out another things

I can enter the menus by using keyboard only and but now it gets hung up in the loading server screen black and a white cursor thing in the upper right corner…


#7

What distro are you using?


#8

linux mint with cinnamon


#9

Add the ppa and do sudo apt install nvidia-396 instead of 390.


#10

I figured out something!

For a few months I have been using reverse mouse buttons thing in mouse settings, when I switched to normal clicking it doesnt crash!

Now it goes to the loading map page with the cursor in upper right corner blinking but it has background music it seems to stop there I will let it run for a while.


#11

Ive updated to nvidia 396

bf4 still gets stuck at loading map screen, 100%cpu no movement after even 15minutes, one time It bounced back to the main menu saying it lost online connection.

when trying to run campaign some of the fonts were broken, showing only some of the letters and buttons were empty boxes.


#12

sudo apt install libvulkan1 libvulkan1:i386 and enable DXVK.


#13

o sheet it works!

tons of flickering from rain effects it seems

I got dxvk 052 btw

trying multiplayer now.


#14

Use DXVK 0.63 or 0.64

You’ll have problems with anything lower.


#15

Hey mutiplayer works!

main problem I have now is I have to set resolution before I enter game and then I cant switch properly between applications and when then when I do It is the lower res settings I use in the game (not very fast gfx card)

How do I update to 064 DXVK?

Thanks a lot!


#16

https://github.com/lutris/lutris/wiki/How-to:-DXVK#manually-updating-dxvk


#17

Hi again, I have added 0.64 to the versions list of dxvk, it doesnt complain or anything, but it also didnt add it to the dropdown list. Anyway I didnt have much problems with 0.52 before,

Earlier when I ran bf4, on some maps I noticed some glitching and flashing on some maps, perhaps specific to certain effects in the game

Later on I played the shanghai map and it worked quite well, without any noticable glitches, But when the round was over and it restarted the same map, it started glitching as hell.

I did restart the entire bf4 and it was normal again if I recall correctly.

But yesterday when running the same map it started glitching right from the start and has done so even after multiple attempts at restarting.

Is there any place you know where I can request a higher priority for investigating the glitches of this specific game?