Battlefield 4 GnuTLS error : The request is invalid (solved)

My system :
Fedora 29
kernel : 4.19.15
gpu : Nvidia GTX 970
driver : 415.27
winehq-staging : 4.1
Running Lutris

When i click " Show Logs " in Lutris I get the following :

In Lutris I click on “Show Logs” and get this error

GnuTLS error: The request is invalid.
GnuTLS error: The request is invalid.
GnuTLS error: The request is invalid.
Running /opt/wine-staging/bin/wine /home/vindican/Lutris_Games/drive_c/Program Files (x86)/Origin/OriginThinSetupInternal.exe
GnuTLS error: The request is invalid.

the following is the output of lauching lutris from the command line:

2019-02-14 10:51:35,651: Running Lutris
2019-02-14 10:51:35,652: Using NVIDIA drivers 415.27 for x86_64
2019-02-14 10:51:35,661: GPU: GeForce GTX 970
2019-02-14 10:51:35,661: GPU: 10DE:13C2 1043:8508 using nvidia drivers
2019-02-14 10:51:35,734: Vulkan is supported
2019-02-14 10:51:35,735: Updating DXVK versions
2019-02-14 10:51:35,836: Connected to as hammerhead_corvette
GnuTLS error: The request is invalid.
Running /opt/wine-staging/bin/wine /home/vindican/Lutris_Games/drive_c/Program Files (x86)/Origin/OriginThinSetupInternal.exe
2019-02-14 10:53:45,523: Game still running (state: running)
2019-02-14 10:53:45,523: Stopping Battlefield 4 (wine)
/usr/lib/python3.7/site-packages/lutris/ Warning: Source ID 936 was not found when attempting to remove it

I do have GnuTLS installed :

Package gnutls-3.6.5-2.fc29.x86_64 is already installed.
Package gnutls-3.6.5-2.fc29.i686 is already installed. 

When i click PLAY it blinks and goes back to the screen in the screenshot.

Any help is appreciated.


1 Like

I have the exact same issue since some days(Probably one or two months, didn’t use origin for some time) with BF4 and Mirrors Edge Catalyst, other games run fine in Origin.
Looking on what happens on the process side for Mirrors Edge, The Mirrors Edge Catalyst Exe and the ActivationUI Exe come up for a second and then both die.
I see the exact same GnuTLS error in the log.

libgnutls30/bionic,now 3.5.18-1ubuntu1 amd64 [installed]

Xubuntu 18.04
Kernel: 4.20.7
GPU: GTX 1060 6GB @ 415.27
Wine Staging 4.1

1 Like

I fixed it. Will post my findings shortly

GnuTLS : The Fix

I removed the directory where Origin and Games resided in. Either through Lutris or my simply deleting the directory itself.

make sure that you have or the equivalent of your distro I am on Fedora 29:

gnutls-3.6.5-2.fc29.x86_64 , gnutls-3.6.5-2.fc29.i686

After a reinstall of the Origin app, I got the same error?!
This time I neded to see the logs to get more information. You can do this by starting Origin and then clicking the monitor icon on Lutris :


I found the following :

008a:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.

It say’s ntlm_auth was not found, so I needed to get windbind , this is found in samba for Fedora 29.

samba-common-tools.x86_64 samba-libs.x86_64 samba-winbind.x86_64 samba-winbind-clients.x86_64 samba-winbind-modules.x86_64

After adding all these packages, do a clean reinstall of Origin, you can move your games to another directory in the meantime.