Battlefield 4 - Audio stutters, frame drops, and CPU spikes

I’m having quite a strange issue I can’t quite seem to find any sort of solution to anywhere online, I’m submitting this for Battlefield 4 but I also get the exact same issue on Battlefield 1 any help at all on this would be amazing…

Detailed Description:

The game(s) will launch just fine and runs decently well, however there’s a few strange issues I get that impact the game’s performance and playability. They appear to be entirely separate since they don’t exactly coincide with eachother.

These issues do not appear to be distro dependent, they happened to me on Debian and on a fresh install of Manjaro. They also still happen regardless of my GPU, i got them with a GTX 970 as well ast a 6800XT. This does not affect other Origin titles such as Titanfall 2.

There’s a few videos of this game running much more smoothly for others so its got to be something with my machine in particular

  1. The audio seems to stutter/restart at random intervals - game-menu-censored.png - AnonFiles

This happens in the main menu and in-game. In the menus, it will simply cut out and start replaying the music over again from the beginning each time. In game, the audio will simply drop and come back randomly.

Sorry the screenshot has the menu covering the graphs but they’re super stable even during the audio restarts.

  1. Sudden CPU usage spikes - ingame-censored.png - AnonFiles

In game, for seemingly no reason, the game spikes heavily in CPU usage and causes frames to drop heavily, this also occasionally affects the physics even… When in a helicopter the ride gets rather bumpy during these spikes with crashing sounds playing.

Troubleshooting tried:

  • Pulse audio tweaks such as lowering latency and fragment sizes
  • Changing the write permissions on some origin files
  • With and without DXVK enabled
  • Enabling “reset pulse audio”
  • With and without ACO enabled
  • With multiple wine versions (BF4 seems to like lutris-jedi-4.20 the most)
  • Changing distros entirely
  • Trying to launch with proton wine versions
  • Using Esync/Fsync
  • Enabling/Disabling Feral GameMode
  • Running in windowed mode (both wine itself and the game)

Probably a few other things but this is just about all I can remember off the top of my head…

(limited to 2 links for being new adding logs in another post)


I can add the lutris debug logs in another thread if desired.

To add to my list of troubleshooting, I tested with lutris-ge-6.9 which was the first “wine 6” based runner that actually ran the game but saw no performance increase or change in the main issues mentioned…

The hunt for a cause continues

Tried switching to pipewire?

Still occurs with pipewire :confused:

Weirdly enough… I upgraded my ram and suddenly this stopped happening.