Back to the main site

Battle.net/WoW Errors - Crashes on Character Swap

Disclaimer: new to reviewing these logs, I see lots of issues, but unsure how to address.

In-Game Issues Observed:

  1. Battle.net doesn’t launch the first time - Majority of the time now I click run, I get the battle.net iconin the system tray, but no GUI. I have to hit Stop then hit Play again when available. Most of the time battle.net launches just fine then.

  2. Character Swap Except Quits WoW - I log into 1 character, log out of that character, and upon selecting another character and clicking login, it’ll start the loading screen then immediately error out.

  3. WoW Freezing - about 1 to 2 times a night during raids, my system will just freeze. Most of the time without any actual combat occuring. No error messages, just locks. The Battle.net launcher is also frozen so I have to force quite both applications.

Things I have tried:

  1. Runners - Nearly every runner available does this. I know the GE (non-proton) ones are preferred, but no difference in the various runner performance The only one that somewhat prevents the character swap exception is the Wine Staging 7.14, but it still has a lot of other errors.

  2. Linux DE - Used Pop!_OS 22.04 originally. Installed Garuda now with the same issues

  3. Runner Options - I have enabled/disabled essentially ever single option in the Runner Options list with no improvement in reducing the errors. I have disabled in various combinations according to other posts. So disabling Fsync, Esync, FSR, and even the DXVK/VKD3D/DLSS options. I did add the locationapi, nvapi, and nvapi64 disable items for DLL overrides that again didn’t seem to do anything for me (because likely it was fixed since the post I read about it).

  4. System Options - Disabling the Lutris and Game modes didn’t seem to have any affect.

  5. Battle.net Reinstall - I’ve re-installed battle.net (and WoW versions) multiple times from scratch

  6. NVIDIA Drivers - I did follow the guide on Lutris’s github for NVIDIA, but the system was already configured and all items installed per directions. docs/InstallingDrivers.md at master · lutris/docs · GitHub

System:
OS: Garuda Linux x86_64
Kernel: 5.18.15-zen1-1-zen
Resolution: 1680x1050
Resolution: 1920x1080
DE: KDE Plasma 5.25.3
WM: KWin (X11)
CPU: AMD Ryzen 5 3600 (12) @ 3.6GHz
GPU: Nvidia GeForce RTX 3060 Ti Lite Hash Rate w/ driver 5.15 (same issue on 5.10)
Memory: 7084MiB / 15906MiB

Logs:
Lutris -d log:
https://paste.ubuntu.com/p/Fczx25Rjbr/

Lutris Show Logs Output:
https://paste.ubuntu.com/p/z8jmd52dHd/

1 Like

Have a look in your World of Warcraft folder for the “retail/Errors” folder and check the .txt files present. If you are using dx12, there is a high chance that the 132 error is caused by a WoW error in how it disposes of the d3d12.dll file during switching. If you add VKD3D_SHADER_CACHE_PATH = 0 as an environment option, this should prevent the 132 error associated with dx12.
As for the issue with the battle.net, I think everyone has that problem. You can repoint the Lutris launcher to Wow.exe for running the game, and only use the battle.net launcher for updates… Make sure you kill off the orphan agent.exe and battlenet processes that Lutris leaves when the game fails to launch.

I had this issue for a while on PopOS too. Can you verify that you tried switching the runner to lutris-ge-lol-6.16-4-x86_64, that specific version stopped the crashing on character swap for me and I was able to raid without freezing/crashes. My launcher is currently set to lutris-ge-lol-7.02-x86_64 after having to reinstall the game this weekend and it hasnt happened yet but I cant guarantee its crash free like the previous version yet.

Set the VKD3D_SHADER value, but no change.

I couldn’t find the lutris-ge-lol-6.16-4-x86_64 nor the lutris-ge-lol-7.02-x86_64 in the download area in Lutris. I installed the versions closest to those, but no dice. These versions aren’t even listed on the main github as releases to download: Releases · GloriousEggroll/wine-ge-custom · GitHub

Re-installed all dependancies and rebooted yet again, no change.

Installed the WoW Classic Lutris installer, but no improvement.

Edit: Found the 7.02 release…it wasn’t in order of other releases. Trying that now.

1 Like

Just tried the lutris-ge-lol-7.02-x86_64 runner and crashed when swapping characters.

I’ll see if I can find the 6.16-4 version and try that.

If that doesn’t work, I’ll see if downgrading my drivers to the 470 or 490 version does anything for me.

Is everyone that is having problems on NVIDIA or are these issues with those with AMD cards too? Definitely eyeing a 6700XT to replace my 3060ti if that is the case…

Okay, well so I booted an old Pop!_OS install on another drive just for the h*ll of it. And Battle.net launched without any issue like the good 'ol days (2021…lol)!

This is on Pop!_OS 20.10 and a Lutris runner version lutris-6.0-rc1-x86_64.

I’m raiding now, so I’ll play around a bit more afterwards to see how I can export these settings to my other setup to see what the trick is. I.e the runner, runner options, or a kernel issue.

So I had a little time today to look at this and will refer you to this thread. Use winetricks to add/install dll or component and select Sapi from the list. This should remove the 132 error when changing between characters. Also, if you use the ProtonUp-Qt appimage, you can easily find runners not included in the Lutris list to add.
The last runner where I do not have issues with battlenet starting is lutris-ge-7.1 (from the ProtonUp-Qt) and adding sapi.dll using winetricks. This may help you with your newer install without having to revert to an older PopOS
EDIT: so test some more and the ge-7.1 has occasional issues with battlenet starting so am now trying 6.21

Still working on this, but wanted to confirm that I wasn’t missing anything. So I can 100% say all the issues that I posted originally is definitely not a hardware nor Blizzard issue. I’ve ran 2 full raid nights (~7 hours) without a single issue. Battle.net launches without any issue on the first click. I can swap characters without any exception and I can raid for many hours without a game freeze.

So I’ll try to snapshot what I have now below and try to slowly swap things over on my other Linux install to see what may or may not fix it.

Lutris Version: 0.5.8.3
Runner: lutris-6.0-rc1-x86_64

NVIDIA Driver: 470.57.02

OS: Pop!_OS 20.10 x86_64
Kernel: 5.11.0-7620-generic
Shell: bash 5.0.17
DE: GNOME 3.38.3
WM: Mutter
WM Theme: Pop
Theme: Pop-dark [GTK2/3]
Icons: Pop [GTK2/3]

Try Disable Lutris Runtime in System Options with the newer install. Enable Hardware Acceleration in the Battle.Net client options as well.
With these 2 changes, I have been running quite happily with the latest Lutris client and Wine-GE 7.24 runner (touch wood it stays this way but on a clean install and my old install, this is working)

Well, finally getting somewhere. I confirmed the lutris-6.0-rc1-x86_64 launches the first time everytime, although there are 3 “fatal errors” that pop-up although everything seems to run fine.

With the “Disable Lutris Runtime” set, the lutris-GE-Proton7-24-x86_64 does launch battle.net correctly without having to kill and restart. I can also swap characters without issue now.

However, I have the same issue I had with another 7.x runner in which all the games need to update every single time Battle.net is opened. i.e. it doesn’t seem to remember that it updated last time. If I run with the 6.0 runner, it updates once and not again, but the 7-24 does it every time.

I guess in general good news that these issues are all contained within the runner and runner options and the outside kernel, video card driver version, linux version, etc… doesn’t seem to have the impact to cause the issues observed earlier.

We’ll see if the 7-24 version can run for hours without a crash/freeze though…otherwise I may just stick with the 6.0 version even if it doesn’t support all these other newer features.

yeah, still having issues with 7-24. Just going to stick with 6.0-rc1 for now. 3 error messages on start up, but other than that super stable and just works on the new system.