Back to the main site

Battle.net WineMenuBuilder


#1

I’m trying to get Battle.net working in Debian Stretch (Stable). I have Wine, Wine32, Wine64, and all of the other dependencies installed, as well as the Mesa Vulkan library. I keep getting an error message about missing a DLL. But when I have Lutris run Battle.net in a terminal, itt tells me that it’s missing winemenubuilder. What should I do?


#2

The error about missing winemenubuilder should be safe to ignore.

What’s the full output you get?


#3

In the next branch, I’m now lying about wine’s stdout for that exact reason.

Screenshot%20from%202018-06-11%2011-08-47


#4

wine: cannot find L"C:\windows\system32\winemenubuilder.exe"


#5

I mean, the full error, what else? That line doesn’t matter, ignore it, pretend like it doesn’t exist :slight_smile:


#6

The wine devs said they disabled winemenubuilder.exe a while back. That might as well be a fixme error. No worries. Look for other errors as winemenubuilder.exe has nothing to do with your problem.


#7

Can you make sure it shows up if someone runs lutris -d


#8

nothing, it’s normal.

i REALLY hope you rethink that decision, and maybe instead just add a “please ignore the previous line” message instead of messing with wine’s output (or, if the line is too annoying, at the very least don’t mess with it if the -d debug command line flag was supplied, as @doryx suggested), because doctoring with “third party” output can always lead to unexpected results.

actually i’m pretty sure that’s the lutris devs, not the wine devs, since wine still uses it. but since lutris doesn’t want to spam your linux desktop’s menu with 3 billion "notepad.exe"s that try to take over your “open file with” default bindings (winemenubuilder has a tendency to run amok on your menu sometimes), they prevent it from running.


#9

i REALLY hope you rethink that decision, and maybe instead just add a “please ignore the previous line” message instead of messing with wine’s output (or, if the line is too annoying, at the very least don’t mess with it if the -d debug command line flag was supplied, as @doryx suggested), because doctoring with “third party” output can always lead to unexpected results.

I fail to see how this could be a problem somehow. We don’t do anything fancy with the logs, it’s just for the user to read, and I surely don’t want them to read something about winemenubuilder and start blaming it for unrelated issues. Adding a warning message would only prevent some users from complaining.


#10

no but the user could. and you’re suggesting removing log information. so if you mess with the logs to prevent users from being too stupid for their own good, that’s your decision of questionable morale, but please at least don’t do it in the debug mode.


#11

I agree that this is not very good practice, but this is a one time thing only, for a message that wouldn’t be displayed hadn’t we disabled winemenubuilder to begin with. The presence of this log line is actively harmful, confusing users and wasting my time.

Displaying that information has been an issue for numerous people, but I still fail to imagine a scenario where it would be harmful to remove it (but that does not mean that there can’t be one).


#12

that’s why i meant just disable the “log manipulation” if debug (as in lutris -d, not wine debug) is enabled. i agree it won’t hurt 99% of the time but especially when debugging lutris you might want to actually check if it’s doing its job of disabling the menubuilder.


#13

old thread but I thought I would chip in

to disable the error message don’t run it :wink:

in system.reg
"winemenubuilder"="C:\\windows\\system32\\winemenubuilder.exe -a -r"
so a simple sed
sed -i '/winemenubuilder/d' ${WINEPREFIX}/system.reg

to removed that by default , look at

loader/wine.inf.in

[Services]
HKLM,%CurrentVersion%\RunServices,"winemenubuilder",2,"%11%\winemenubuilder.exe -a -r"

#14

@Firerat you rock! I never knew that it was possible to do that!