Battle net / warcraft not opening

Hi all. In need of a little help here.
As of this morning WoW just stopped working. It just fails to load.
I’ve tried the usual stuff, updated drivers, ran apt-get upgrade, reinstalled WoW via lutris about 6 times now, disabled dxvk, tried different versions of dxvk and wine, reinstalled system wine, checked all dependencies to see if they need reinstalling, etc etc.
I ran “lutris -d” from terminal and I get this…

DEBUG    2019-03-25 12:50:32,659 [display._get_vidmodes:15]:Retrieving video modes from XrandR
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/lutris/", line 26, in wrapper
    return function(*args, **kwargs)
  File "/usr/lib/python3/dist-packages/lutris/", line 299, in configure_game
    gameplay_info =
  File "/usr/lib/python3/dist-packages/lutris/runners/", line 832, in play
    launch_info = {"env": self.get_env(os_env=False)}
  File "/usr/lib/python3/dist-packages/lutris/runners/", line 718, in get_env
    env = super(wine, self).get_env(False)
  File "/usr/lib/python3/dist-packages/lutris/runners/", line 149, in get_env
    runtime_env = self.get_runtime_env()
  File "/usr/lib/python3/dist-packages/lutris/runners/", line 744, in get_runtime_env
    if entry in wine_path:
TypeError: 'in <string>' requires string as left operand, not NoneType

Can anyone shed any light on what this means as it’s now past my knowledge as a casual user.
If it matters, I have a R5 1600x and a GTX1060 on 419, ubuntu 18.04
many thanks for any help.

1 Like

I can report the same. After the lutris update I applied this morning, none of my games launch, including Not just you my man.


Disabling Lutris runtime and enabling system libraries has fixed it for me.

Open Lutris > right click your game >configure, then go to the “system options” tab and check the necessary boxes.


What @slimithy said works, Linux Mint 19.1 with Nvidia 418 drivers. Even restored the system previous to this solution :confused:
Thank You :wink:

1 Like

And which are boxes I must select ??
I run Kubuntu 18-10

1 Like

The ones that say “Disable Lutris runtime” and “prefer system libraries”, which are the top 2 boxes.

But I think you only need to set “disable lutris runtime”.


Thank slimithy, now is ok.
I have select enable : Prefer System libraries
Disable Lutris runtime

Thy again

1 Like

Fixed my issue! :DDD (slimithy’s post about lutris runtime/system)