Back to the main site

Battle.net: Required DLL could not be found

Suddenly Battle.net stopped working with the required-dll-not found error. DXVK is disabled, so the instruction in https://github.com/lutris/lutris/wiki/Game:-Blizzard-App does not apply. My system does not support dxvk. I have all dependencies, since everything was working until about last week.

I tried reinstalling but the installer hangs with not finding Battle.net.exe - no wonder because the installer failed without even creating the necessary directories. I’ve already had this error about 4 weeks ago but at the time there was an unpublished installer version that worked. Now the unpublished installer version is gone and replaced by a script to install software for a spanish private server.

Edit After trying several older wine versions tkg_4.6 worked. But a functional installer would still be nice especially because I’m going to update to buster soon … And please get rid of that WarSages stuff. Lutris should not support rip-offs.