launcher not appearing and WoW Classic crashing


I reinstalled my system from scratch last week and have had issues with BattleNet and WoW Classic since. Never had any problems before.

I have no idea if the two are connected so to not spam the forum I put them in one post.

  1. BattleNet launcher not opening
    About 50% of the time the login screen for the BattleNet launcher does not appear after clicking the Play button. However, the button changes, indicating that the game is running and I can quit the game by clicking again as usual. That happens with running Lutris normally and using lutris -d. But it is in no way reproducible. If it doesn’t work one way trying it the other way sometimes solves it, sometimes I have to restart the system sometimes nothing helps. Feels completely random.

  2. Game freezing
    When I do get to play WoW Classic the game and the launcher in the background sometimes crash. No WoW or Windows error message is given. Happened only a few times until now so I haven’t been able to reproduce it.

I also had the #132 error on loading screens but have already found the threads concerning the sapi.dll and installed it.

The log files below are from a working launch using lutris -d but contained quite some error messages so I thought they might be of some value despite not exactly representing the isue(s). I started Lutris, then WoW Classic, logged into one of my characters, logged out again and closed WoW then Lutris.

What I also noticed is that starting the game (mainly when connecting to and logging in to the realms) takes a lot longer than before and sometimes even freezes for a couple of seconds (and Manjaro asking me to force kill or wait) before I get to the character selction screen.

Lutris -d:


Any help appreciated.

Navigate to your WoW Prefix (~/games/World of Warcraft or where ever you put the installation) and find the drive_c/ProgramData/ folder. If you have multiple Agent.xxxx folders present, there is a simple workaround, if it is just the Agent.8009 then a different approach.

1 Like

Two Agent folders in my prefix:
Agent.7984 and Agent.8009

first in Lutris, go to the Game options tab and add the following to the arguments:
–exec=“launch Pro” (if you DON’T have overwatch installed, or “launch D3” if you DON’T have Diablo installed).
Save and in the Agent.8009 folder, rename the Agent.exe to Agent.exe.old
Next copy the Agent.exe (should be 5.5mb) from the Agent.7984 folder to the Agent.8009 folder.
Keep the file browser open, and start the launcher in Lutris. It should show an Overwatch or Diablo 3 branded login screen and then the launcher. When it is ready, it should take you to the Overwatch or Diablo 3 game page. Navigate to the WoW page and you should be able to do the update.
Doesn’t always work with the update, but at least you can run the game.

1 Like


I did get the Overwatch login. So that worked. But after swapping to WoW Classic there was no Update. Game is running anyway. Still got the short freeze when connecting.

Any idea if that could also have been the reason/solution for the ingame crashes?

Check in your Program Files (x86)/World of Warcraft/_classic/Errors folder

Two errors in there, both from past error #132 crashes.

Nothing recent? WoW is extremely hard on CPU and memory. I OC some b-die DDR4 ram from 3200CL14 to 3733CL14 and on a hot day my ram would hit 47 C and I would get intermittent crashes in WoW even though it past all the stress tests. That would be one thing to look at - RAM, or swapping to disk. Nothing in the logs I could see.

1 Like

Thank you so much for your help Jhu! :kissing_heart:
You have made two of our children very happy with your problem solving. We were very desperate.
Your solution helped us a lot for the two old PCs.

I’ll keep that in mind - so far no crashes.
But I’m almost certain it’s not a hardware issue. Didn’t change anything and it started only a week ago after setting up my system from scratch.

I am receiving similar issues as reported.

About 50% of the time when I launch I never receive a sign-on prompt. I “Stop” and hit “Play” again in an attempt to fix.

Off and on again the game (WoW classic WoTLK) and my client will randomly freeze after x amount of time. Sometimes 20 minutes, sometimes 3 hours, really sporadic times.

I’ve tried Jhu’s suggestion but do not have those specific agent folders. Attempting to implement what he suggested, copying the agent from the older folder into the newer causes hard crashes attempting to play the battlenet launcher.

Has anybody figured out what the consistency issue is yet? If there are any logs I can provide or ways to be of further assistance let me know and I will be happy to oblige!

Hold up - those directions are NOT valid today - do not use them - they were for a bug in the agent.exe which bliazzard fixed a few days later!!!

To fix the sign on issue with launching, either disable esync and fsync or Visit this link and make the script. Also, in the launcher, goto settings and set to exit completely when I launch a game.

If you did copy the agent files around, rename the folder in ProgramData to and run the launcher again to force it to download the most recent agent folders.

Hi Jhu, I’ve already reverted the agent fix after realizing that it did not work for me.

Can you discuss/share more what you mean by “” script? I don’t see anything linked. Also, I’m not sure what fsync/esync are either, but I’m pretty sure I don’t have them enabled.

The agent was actually working mostly-fine prior to today. I’ve now tried to load it 10+ times and am not being presented a log in screen. Below are my logs. Any ideas what is causing this?

Started initial process 7126 from /home/somedude36/.local/share/lutris/runners/wine/lutris-7.2-2-x86_64/bin/wine /home/somedude36/Games/blizzard/drive_c/Program Files (x86)/ –exec=“launch Pro”
Start monitoring process.
esync: up and running.
WARNING: radv is not a conformant Vulkan implementation, testing use only.
WARNING: radv is not a conformant Vulkan implementation, testing use only.
WARNING: radv is not a conformant Vulkan implementation, testing use only.
[1111/] WSALookupServiceBegin failed with: 0
WARNING: radv is not a conformant Vulkan implementation, testing use only.

Use this link and scroll down to the trouble shooting section for the Also look on your runner options tab (from clicking configure for the game in lutris) and enable advanced options down the bottom to ensure that esync and fsync are not enabled.

As for the other issue, run lutris -d in terminal and then launch and copy the output to a file and share the file (don’t paste the output here). Use or something similar

Thanks for the kill script, I have implemented it. I also turned off esync and fsync in my runner options as you indicated. I’ve only played a few hours since, but so far no crashes in the middle of a session so that is good!

I’ve also launched the session a few times now without issue.

Crash on load happened however. I’ve pasted the logs as requested, if this requires a different ticket let me know.

Check in winetricks (wine glass->winetricks) to see if mf has been added to your default prefix. Also see if sapi has been added. If they are missing, click the checkbox to install them.

By “mf” I’m assuming that you mean “MS Media Foundation”? It is not installed, so I will go ahead and add that.

I do not see anything named “sapi”. I’m looking in winetricks → default prefix → Install a Windows DLL or component

Pasted from another thread:

Some things which made client stop crashing for me were:
Go to Configure options for World of Warcraft in Lutris
Go to Runner options
Disable Esync
Disable Fsync

In battlenet client, also go into it’s settings and disable hardware acceleration

Inside wow change to DirectX 11

Also I have had other problems with wayland with other apps, I use X for now and can report WoW runs awesome

Also I have been having issues with firewalld on fedora 37. So before I want to start up and wow I sudo systemctl stop firewalld, battlenet starts up heaps quicker and everything runs great

Check here - discord link or

This will be needed if the new release is dx12 only - some times this is enabled, but if you do have crashes with dx12 enabled at the character loading screen (can be initial or any other time), this should fix it it.