Launcher.exe could not be found

Hi, I’m getting Launcher.exe could not be found when trying to run
I ran the 64-bit installer. How do I go about solving this?

I’m having the same issue with the scripts and the Hearthstone script. None of these seem able to complete. From what I can see the scripts create the prefix but they don’t download the Battlenet client.

I’m running Solus, with Lutris 4.12. I tried the 64 bit and 32 bit scripts and the Hearthstone script. Wine versions used were 2.9 and 2.10 staging

I’ve noticed as well when browsing the virtual drive that the folder within “program files” is missing indeed.

If the folder is missing, that means that the install didn’t complete properly.

You have to check the console output of the install process to inspect for possible issues (usually a runtime issue with winetricks)

I experienced the same problem. The output of the console was:

wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe" err:wineboot:ProcessRunKeys Error running cmd L"C:\\windows\\system32\\winemenubuilder.exe -a -r" (2) err:module:load_builtin_dll failed to load .so lib for builtin L"WLDAP32.dll": cannot open shared object file: No such file or directory

In my case (Arch Linux) the installation of lib32-sqlite solved the problem.

1 Like

Thanks! I will add that to the package’s dependencies :slight_smile:

Oh, that seems to do the trick. I’m getting up the Blizzard install window now at least. Still installing though, but I’m getting further than usual.

Edit: Until it was done and I tried to login. Keep getting Helper.exe has encountered a serious problem.
Can’t enter the password either, not sure if the problems are connected.

Edit 2: Both problems solved by changing Wine version FROM System (2.10) (Default) TO staging-2.7-x86_64

Edit 3: Could login once, but now my login Window looks weird (Didn’t do that the first time). I can hit login, but the authenticator window which shows up doesn’t send me the auth code this time when changing to SMS.

Edit 4: I’m able to play if I chose “Continue offline” and login directly thru the game. However, I disabled my SMS authentication as I could not get it to work. The phone app works though.

No one got a solution for the cookie problem?

With a new update from Blizzard, the launcher directory has changed from to Blizzard App

I try to modify the install script and install manually but I’m stuck with an error about missing runner field

Here is what should be:

- setup:
- bnetconfig:
  arch: win64
  args: battlenet://WTCG/
  exe: drive_c/Program Files (x86)/Blizzard App/ Launcher.exe
  prefix: $GAMEDIR
- task:
    arch: win64
    description: Creating 64bit Wine prefix.
    name: create_prefix
    prefix: $GAMEDIR
- task:
    app: dotnet45
    description: 'Winetricks: Installing dotnet45'
    name: winetricks
    prefix: $GAMEDIR
- task:
    arch: win64
    description: 'Wine: Setting vcruntime140 to native'
    key: vcruntime140
    name: set_regedit
    path: HKEY_CURRENT_USER\Software\Wine\DllOverrides
    prefix: $GAMEDIR
    value: native
- task:
    app: win10
    description: 'Winetricks: Setting Windows 10 mode for Wine'
    name: winetricks
    prefix: $GAMEDIR
- merge:
    description: Copy config
    dst: $GAMEDIR/drive_c/users/$USER/Application Data/
    src: bnetconfig
- task:
    arch: win64
    args: battlenet://WTCG/
    description: 'Installing Blizzard App


      Important: Do not log into Blizzard App, just close it when it ask for your
      Username/Password. Then wait about a minute for the install to finish.'
    executable: setup
    name: wineexec
  version: staging-2.18-x86_64

exactly the same probleme

I’m trying to install battlenet so I can play starcraft 2. I logged in and exited the client normally and now it seems to be stuck on this screen. I’m assuming this isn’t normal and I’m not sure what to do at this point.

running arch linux

If you want to play Starcraft 2, use the Starcraft 2 installer.

Also, Blizzard App is annoyingly not shutting down lately, so once you close the App itself, Lutris is still waiting for it to finish. Just open a terminal and type “killall Agent.exe”.

And oh yeah, Blizzard can’t seem to make up their mind on calling the directory for the launcher “Blizzard App” or “”. We have already changed all installers one time. But it if you have that error again, just locate the correct folder.

When I try to install and run
The file ~/Games/battlenet/drive_c/Program Files (x86)/ Launcher.exe could not be found

When I try tin install and run Wow.
The file ~/Games/world-of-warcraft/drive_c/Program Files (x86)/ Launcher.exe could not be found

uname -a
4.13.0-37-generic #42~16.04.1-Ubuntu SMP Wed Mar 7 16:03:28 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Installers are working fine atm. With your uname -a you really ain’t giving any info, so here comes my general advice:

If you don’t have the required dependencies installed in your system, the Blizzard App installer won’t be able to run, so will complete without doing anything. So when Lutris points to the Blizzard App afterwards, there is nothing there. Install the dependencies, install again.

Looks like as of about April 19 or 20 - this problem is Up again. Basically non-existent battlenet directory after the installation process.
Yes - all dependencies and all was installed after a clean remove/purge what not.

Hope for anyone with more clues than me :smiley:

I’m also unable to install (and Hearthstone). Has anyone been able to solve it or know where I can start digging for clues? I know Python, but not how Lutris install scripts or the dependencies work.

EDIT: I managed to get it installed by creating a wine prefix manually and installing corefonts, winhttp and wininet, setting winhttp, wininet and dnsapi to “native, builtin” in library overrides and rasapi32 to “native”. I also removed the LocationAPI.dll in {wine_prefix}/drive_c/Program Files (x86)/Hearthstone/Hearthstone_Data/Plugins/. Finally I added -force-d3d9 as additional command line parameter in Battlenet game settings for Hearthstone to avoid the black screen. It even starts quicker than previous installs.