Invalid Installation Folder

I’m trying to install World of Warcraft on a fresh Fedora 27 build. Installed all of the dependencies listed on the github READMEs and the installer downloads and runs but it throws an error of “Invalid Installation Folder” and I can tell from the free space it thinks it has it is trying to install into my / partition somewhere that I don’t have write permissions to rather than my /games partition. I haven’t been able to find anywhere that allows me to specify where it installs rather than very first screen where I tell it to install into /games/world-of-warcraft and that successfully setups the prefix, etc. Any help would be greatly appreciated.

Do you have permission to use /games as your user? If you made the folder with sudo, make sure you chown-ed it to your user.

Yep, definitely have write permissions. It should be trying to install it to $GAMEPREFIX/drive_c/Program Files (x86)/ and I have write permissions to all of the previous folders but no folder. It’s weird because on the screen that says invalid installation folder I can pick a new path for it to install but it will error out before I can get a new folder chosen.

Ok, I got this particular problem solved. It was a NVIDIA Optimus problem. I had to enable primusrun and now I can install Launcher. Very strange error for what the problem was.

Now I’m getting a Failed to create graphics context error but I see some other forum posts related to the same error so I’m trudging through those now.

Yeah, you need to have drivers installed correctly with Optimus. I don’t have it myself, but some people did note that they got it working.

Make sure you have proprietary drivers.

I recently had this issue. I decided to do nothing, and a reboot fixed it for me.