"Failed to create a graphics context"

I just found Lutris and was excited that people had gotten to work; however, I cannot get to login, it crashes after I enter my password and click the button with:

Failed to create a graphics context.

More help: BLZBNTBNA0000000A

My system:

Void Linux (runit init instead of systemd)
Lenovo Y700 15ACZ laptop
AMD FX-8800P
AMD Radeon R9 M385X - 2048 MB, Core running the xf86-video-amdgpu-18.0.1_1

I am able to get past the login with the regular/system wine(32bit); however, it will not play the game. When I run Lutris, it installs and looks much, much better than the system wine, but, after logging in, it goes to a black screen and then gives me the above error.

I’ve played around with configuration options, wine configuration and the PBA-3.3-staging that was recommended, all to no effect.

I searched the Internet and found that people with Windows had this problem and needed dxdiag to figure out the issue; however, I could not find any information for wine/Lutris/PlayonLinux/et al.

Anybody have any ideas? Thank you in advance!

Likely GPU driver related. See:

Blizzard’s Own Support Link at does also state:

This error is also occurring with some Linux-based installations using WINE.

so it could even be that packages on Void Linux are lagging behind other distributions like Ubuntu 17.10

not much else i can say to help. :man_shrugging:

What game?

Did you use the actual installer for that game?

That said, graphic context most likely has to do with your Video drivers. Blizzard App is 32 bit, but most games are 64 bit. Make sure you have that set up for AMDGPU.

Thank you both for taking a look. Yes, I set up the game through the Lutris “Install” button. As far as setting up the 32bit, do you mean installing the 32bit driver versions of the AMDGPU?

I was thinking so at first, but the regular wine will run and install WoW through, but won’t play it. In Lutris, I can’t get past the login, so there’s a setting somewhere I’m missing, or, at least, that’s my thought process.

Edit: The Void package is the 32-bit wine, so that may have something to do with it, rather than the 64-bit installed through Lutris… just thinking out loud here.

Wine in void currently is 32bit only

Get Void to make biarch Wine. :wink:

You need 32 bit for Blizzard App. You need 64 bit for Blizzard Games. Though Blizzard did have / does have 32 bit clients for certain games, which you can set in Blizzard App in the game options. Lutris makes 64 bit prefixes, so you won’t be able to use those. Your best bet is to use your own 32 bit prefix, and hope that WoW is still able to run in 32 bit.

For anyone that gets this error message on Arch Linux, I fixed it by installing lib32-nvidia-utils package from the official repos.

Yeah, i just migrated over to Manjaro tonight. I had to install lib32-nvidia-utils-beta to fix that issue (I use the beta nvidia drivers via AUR).

Was actually trying to figure out the crash on login to the client for the newest universal script that enables DXVK and uses esync-3.14. Still need to try it again, but installing the world-of-warcraft only variant seemed to work as intended (though this has DXVK disabled by default)

(now, if DLLs would stop getting corrupted when fetched that would be great.)