Back to the main site

Battle.net client doesn't install


#1

When i tried to install keeps poping up a a message “We’re having trouble launching the Blizzard Update Agent. Please wait one minute and try again…” i’ve installed all the dependencies from the bnet guide and the “get out the hell of dependencies”, here’s the log while installing.

004a:fixme:kernelbase:AppPolicyGetThreadInitializationType 0xfffffffa, 0xaefea0
0048:fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
0048:fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported
005b:fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
005b:fixme:wbemprox:client_security_SetBlanket 0x7cd5d918, 0x159a40, 10, 0, (null), 3, 3, (nil), 0x00000000
005b:fixme:wbemprox:client_security_Release 0x7cd5d918
005b:fixme:wbemprox:enum_class_object_Next timeout not supported
005b:err:ntdll:NtQueryInformationToken Unhandled Token Information class 24!
005b:fixme:ver:GetCurrentPackageId (0x33fe14 (nil)): stub
005d:fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
005d:fixme:wbemprox:client_security_SetBlanket 0x7c537918, 0x1791c8, 10, 0, (null), 3, 3, (nil), 0x00000000
005d:fixme:wbemprox:client_security_Release 0x7c537918
005d:fixme:wbemprox:enum_class_object_Next timeout not supported
005d:err:ntdll:NtQueryInformationToken Unhandled Token Information class 24!
0062:fixme:ver:GetCurrentPackageId (0x1c7fe9c (nil)): stub
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 152 (GLX)
Minor opcode of failed request: 3 (X_GLXCreateContext)
Value in failed request: 0x0
Serial number of failed request: 183
Current serial number in output stream: 187
0058:err:ntdll:RtlpWaitForCriticalSection section 0x1769bc “?” wait timed out in thread 0058, blocked by 0051, retrying (60 sec)
0066:fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
0066:fixme:wbemprox:client_security_SetBlanket 0x7cd4f918, 0x159a40, 10, 0, (null), 3, 3, (nil), 0x00000000
0066:fixme:wbemprox:client_security_Release 0x7cd4f918
0066:fixme:wbemprox:enum_class_object_Next timeout not supported
0066:err:ntdll:NtQueryInformationToken Unhandled Token Information class 24!
0066:fixme:ver:GetCurrentPackageId (0x33fe14 (nil)): stub
0068:fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
0068:fixme:wbemprox:client_security_SetBlanket 0x7c4f3918, 0x1791c8, 10, 0, (null), 3, 3, (nil), 0x00000000
0068:fixme:wbemprox:client_security_Release 0x7c4f3918
0068:fixme:wbemprox:enum_class_object_Next timeout not supported
0068:err:ntdll:NtQueryInformationToken Unhandled Token Information class 24!
006d:fixme:ver:GetCurrentPackageId (0x1c7fe9c (nil)): stub
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 152 (GLX)
Minor opcode of failed request: 3 (X_GLXCreateContext)
Value in failed request: 0x0
Serial number of failed request: 183
Current serial number in output stream: 187
0071:fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
0071:fixme:wbemprox:client_security_SetBlanket 0x7cd2b918, 0x159a40, 10, 0, (null), 3, 3, (nil), 0x00000000
0071:fixme:wbemprox:client_security_Release 0x7cd2b918
0071:fixme:wbemprox:enum_class_object_Next timeout not supported
0071:err:ntdll:NtQueryInformationToken Unhandled Token Information class 24!
0071:fixme:ver:GetCurrentPackageId (0x33fe14 (nil)): stub
0074:fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
0074:fixme:wbemprox:client_security_SetBlanket 0x7c5da918, 0x1791c8, 10, 0, (null), 3, 3, (nil), 0x00000000
0074:fixme:wbemprox:client_security_Release 0x7c5da918
0074:fixme:wbemprox:enum_class_object_Next timeout not supported
0074:err:ntdll:NtQueryInformationToken Unhandled Token Information class 24!
0079:fixme:ver:GetCurrentPackageId (0x1c7fe9c (nil)): stub
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 152 (GLX)
Minor opcode of failed request: 3 (X_GLXCreateContext)
Value in failed request: 0x0
Serial number of failed request: 183
Current serial number in output stream: 187
007e:fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
007e:fixme:wbemprox:client_security_SetBlanket 0x7cd2a918, 0x159a40, 10, 0, (null), 3, 3, (nil), 0x00000000
007e:fixme:wbemprox:client_security_Release 0x7cd2a918
007e:fixme:wbemprox:enum_class_object_Next timeout not supported
007e:err:ntdll:NtQueryInformationToken Unhandled Token Information class 24!
007e:fixme:ver:GetCurrentPackageId (0x33fe14 (nil)): stub
0080:fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
0080:fixme:wbemprox:client_security_SetBlanket 0x7c510918, 0x1791c8, 10, 0, (null), 3, 3, (nil), 0x00000000
0080:fixme:wbemprox:client_security_Release 0x7c510918
0080:fixme:wbemprox:enum_class_object_Next timeout not supported
0080:err:ntdll:NtQueryInformationToken Unhandled Token Information class 24!
0085:fixme:ver:GetCurrentPackageId (0x1c7fe9c (nil)): stub
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request: BadValue (integer parameter out of range for operation)


#2

installer probably broken again i dont know why they still show status gold on overwatch without even testing.


#3

I regularly test Overwatch script and it works just fine, tried it a few minutes before.
The issue is that something is not configured properly on your system.
For a start, can you follow this page and provide some info?


And the version of Lutris you have.


#4

Not sure why, after a few reboots just worked…


#5

Finally I have installed Battle.net
From Lutis Games I selected firts the China (CN ) version, and after It was installed I selct from right menu “Install another Version” and then I from again Lutris I installed " Experimental All-in-one-version"

During instalation of the program was suspended, showing loading news files
I waited 10 minutes and then Kill all wine process.

After, when I on/play Battle.net it was right, and show European version not China


#6

Use Overwatch installer instead.


#7

I only have this issue when I try to use older versions of Wine. 4.x-staging works grand even in PlayOnLinux.