cannot update/install SC2/HOTS

Hi guys,

After installing the app using I’m trying to make SC2 run. But for some reason the Bnet launcher is unable to install the game. It’s stuck on 'Initializing before giving up with error an error ->

This error basically says ‘no permission’, but I don’t believe it, as my useraccount has full write access on the files, and:

  • Diablo 3 installs, works and is playable
  • Overwatch installs, works and is playable
  • Starcraft 1 installs, works and is playable
  • HOTS doesnt install, different error (but roughly the same meaning) ->

I’ve tried reinstalling the launcher a couple of times (even on a different filesystem), but my feeling is that it has something to do with how the engine (I think both games share an engine) is being handled (or handles it’s files).

Trying to copy the files from my Windows VM didn’t fix the issue (it still needs to update, but for some reason it can’t touch the files).

It does, however, create the SC2Data/HeroesData folder in the destination folder…

Anyone a clue?


1 Like

Hi folks,

Finally had the time to do some extra research:

EDIT: When running the launcher with Proton 3.16 (the one that came with Steam, does seem to work!), it’s installing! :slight_smile: but alas, it doesn’t start…

Did you try to reinstall Battle.Net recently? I just launched it with last Wine version tkg-4.5 64 bits, it works.

Thanks for the reply!

I have, but unfortunately it still doesn’t install. Bnet itself works mostly just fine, but for some reason I cannot install HotS or SC2, all the other games I’ve installed and tried work (see my first post with the test results)

What is your setup (OS + Wine settings), and did you use the same installer?

Mine a.t.m. are the defaults from the installer, except that I changed to tkg-4.5-x86_64

I haz moar details, the problem is with the launcher, not with the game.

When I copy over the files from my Windows installation, and start the launcher with my network connection interrupted (so it doesn’t know whether or not to update the game) I can start and play the game!

However, as soon as the launcher finds out it needs to touch the files (and it does that everytime a ‘state change’ (stopping/starting a game/the launcher) is detected) it breaks again…