Back to the main site

Battle.net Agent fails during installation


#1

Im trying to get battlenet installed and working on my Linux Mint PC, but the installer gives me a Battlenet Agent error.
I followed this DXVK installation guide, installed everything as directed, including all dependancies, wine staging, wine tricks etc…
I then tried to install the launcher through the Lutris app.

Unfortunately the install gets stuck at about 50%.
I tried installing again on a different drive (in case my main drive was NTFS) but I get the same error.

Here are the installation logs. I would really appreciate some advice, thanks!

Running /home/jordan/.local/share/lutris/runners/wine/tkg-4.0-x86_64/bin/wine /home/jordan/.cache/lutris/installer/battlenet/setup/Battle.net-Setup.exe
000b:fixme:winediag:start_process Wine Staging 4.0 is a testing version containing experimental patches.
000b:fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org.
002a:fixme:kernelbase:AppPolicyGetThreadInitializationType 0xfffffffa, 0xb1fea0
0009:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
0009:fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
0009:fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported
004c:fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
004c:fixme:wbemprox:client_security_SetBlanket 0x7d283938, 0x15d410, 10, 0, (null), 3, 3, (nil), 0x00000000
004c:fixme:wbemprox:client_security_Release 0x7d283938
004c:fixme:wbemprox:enum_class_object_Next timeout not supported
004c:fixme:ver:GetCurrentPackageId (0x33fe14 (nil)): stub
004e:fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
004e:fixme:wbemprox:client_security_SetBlanket 0x7cb61938, 0x17bb20, 10, 0, (null), 3, 3, (nil), 0x00000000
004e:fixme:wbemprox:client_security_Release 0x7cb61938
004e:fixme:wbemprox:enum_class_object_Next timeout not supported
0052:fixme:ver:GetCurrentPackageId (0x1b9fe9c (nil)): stub
004e:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  183
  Current serial number in output stream:  187
004a:err:ntdll:RtlpWaitForCriticalSection section 0x199bec "?" wait timed out in thread 004a, blocked by 0031, retrying (60 sec)
0055:fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
0055:fixme:wbemprox:client_security_SetBlanket 0x7d3c9938, 0x15d410, 10, 0, (null), 3, 3, (nil), 0x00000000
0055:fixme:wbemprox:client_security_Release 0x7d3c9938
0055:fixme:wbemprox:enum_class_object_Next timeout not supported
0055:fixme:ver:GetCurrentPackageId (0x33fe14 (nil)): stub
0057:fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
0057:fixme:wbemprox:client_security_SetBlanket 0x7cb7f938, 0x17bb20, 10, 0, (null), 3, 3, (nil), 0x00000000
0057:fixme:wbemprox:client_security_Release 0x7cb7f938
0057:fixme:wbemprox:enum_class_object_Next timeout not supported
005b:fixme:ver:GetCurrentPackageId (0x1b9fe9c (nil)): stub
0057:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  183
  Current serial number in output stream:  187
005e:fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
005e:fixme:wbemprox:client_security_SetBlanket 0x7d2ae938, 0x15d410, 10, 0, (null), 3, 3, (nil), 0x00000000
005e:fixme:wbemprox:client_security_Release 0x7d2ae938
005e:fixme:wbemprox:enum_class_object_Next timeout not supported
005e:fixme:ver:GetCurrentPackageId (0x33fe14 (nil)): stub
0061:fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
0061:fixme:wbemprox:client_security_SetBlanket 0x7cca3938, 0x17bb20, 10, 0, (null), 3, 3, (nil), 0x00000000
0061:fixme:wbemprox:client_security_Release 0x7cca3938
0061:fixme:wbemprox:enum_class_object_Next timeout not supported
0066:fixme:ver:GetCurrentPackageId (0x1b9fe9c (nil)): stub
0061:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  183
  Current serial number in output stream:  187

#2

FIXED THE ISSUE!
For some reason, I did not have all the relevant 32-bit libraries, so I ran the following command:

sudo apt install libnvidia-gl-418:i386

Just change the 418 to whatever version you have installed!