Back to the main site

Banished Steam/wine dosn't work


#1

There is no sound. The game crashes every few seconds. I tried using the auto save, but that only goes to one minute which isn’t often enough. When installing you can’t even see the text in steam. wine gives lots of error messages. I suspect wine needs to be configured/is missing one or more things. Also the FPS is in the basement.


#2

Still having problems. winehq.com says that wine 3.0-rc5 works with banished. Please add wine 3.0-rc5. you only go up to 3.0.


#3

3.0-rc5 is a release candidate hence the rc. 3.0 has those bug fixes included.


#4

I selected 3.0 and it ran for about 8 minutes then crashed. No error message. No mods are enabled.


#5

Brilliant!


#6

Have you tried with Wine Staging 2.21?


#7

Wine Staging 2.21 still has the same crash after a few minutes.


#8

I wish I could play for more than a few minutes at a time. Unfortunately the dev posted that the Linux port has been canceled!


#9

Perhapsthis will help:

0x00e8982b: int $3
Modules:
Module Address Debug info Name (64 modules)
PE 350000- 3c4000 Deferred chrome_elf
PE 400000- 874000 Export steamwebhelper
PE 880000- 4e6d000 Export libcef
PE 52b0000- 52d1000 Deferred winh264
PE 10000000-100ab000 Deferred sdl2
PE 7a820000-7a824000 Deferred opengl32
PE 7b410000-7b5ad000 Export kernel32
PE 7bc10000-7bc14000 Deferred ntdll
PE 7d750000-7d753000 Deferred api-ms-win-core-sysinfo-l1-2-1
PE 7d7b0000-7d7be000 Deferred setupapi
PE 7d820000-7d823000 Deferred mfplat
PE 7d840000-7d843000 Deferred mfreadwrite
PE 7e070000-7e073000 Deferred mf
PE 7e080000-7e083000 Deferred api-ms-win-core-file-l2-1-1
PE 7e3b0000-7e3b3000 Deferred api-ms-win-core-localization-obsC:\windows\system32\api-ms-win-core-localization-obsolete-l1-2-0.dll
PE 7e3c0000-7e3c3000 Deferred api-ms-win-core-datetime-l1-1-1
PE 7e3d0000-7e3d3000 Deferred api-ms-win-core-string-l1-1-0
PE 7e3e0000-7e3e3000 Deferred api-ms-win-core-localization-l1-C:\windows\system32\api-ms-win-core-localization-l1-2-1.dll
PE 7e400000-7e403000 Deferred api-ms-win-core-fibers-l1-1-1
PE 7e410000-7e413000 Deferred api-ms-win-core-synch-l1-2-0
PE 7e420000-7e424000 Deferred uxtheme
PE 7e610000-7e614000 Deferred winex11
PE 7e850000-7e853000 Deferred wtsapi32
PE 7e860000-7e863000 Deferred dxva2
PE 7e880000-7e884000 Deferred dxgi
PE 7e8a0000-7e8a4000 Deferred d3d11
PE 7e910000-7e914000 Deferred wined3d
PE 7ea30000-7ea34000 Deferred d3d9
PE 7ea70000-7ea75000 Deferred jsproxy
PE 7ea90000-7ea96000 Deferred winhttp
PE 7ead0000-7eada000 Deferred mpr
PE 7eb00000-7eb18000 Deferred wininet
PE 7eb70000-7eb81000 Deferred urlmon
PE 7ec10000-7ec13000 Deferred secur32
PE 7ec40000-7ec43000 Deferred ncrypt
PE 7ec50000-7ec53000 Deferred dhcpcsvc
PE 7ec70000-7ec73000 Deferred dwrite
PE 7ecd0000-7ecd4000 Deferred iphlpapi
PE 7ed00000-7ed03000 Deferred netapi32
PE 7ed30000-7ed34000 Deferred dwmapi
PE 7ed40000-7ee07000 Deferred cryptui
PE 7ee30000-7ee33000 Deferred usp10
PE 7ee90000-7ee94000 Deferred dbghelp
PE 7ef00000-7ef0a000 Deferred winspool
PE 7ef30000-7efc9000 Deferred comdlg32
PE 7f020000-7f061000 Deferred crypt32
PE 7f0f0000-7f0f4000 Deferred wintrust
PE 7f120000-7f135000 Deferred oleacc
PE 7f180000-7f183000 Deferred userenv
PE 7f1a0000-7f1cf000 Deferred comctl32
PE 7f290000-7f294000 Deferred ws2_32
PE 7f2d0000-7f2d4000 Deferred imm32
PE 7f300000-7f308000 Deferred oleaut32
PE 7f430000-7f590000 Deferred shell32
PE 7f660000-7f669000 Deferred msacm32
PE 7f6a0000-7f6a4000 Deferred rpcrt4
PE 7f720000-7f728000 Deferred ole32
PE 7f850000-7f8c8000 Deferred winmm
PE 7f910000-7f914000 Deferred advapi32
PE 7f980000-7f987000 Deferred gdi32
PE 7fab0000-7faec000 Deferred user32
PE 7fc00000-7fc08000 Deferred shlwapi
PE 7ffc0000-7ffc4000 Deferred psapi
PE 7ffd0000-7ffd4000 Deferred version
Threads:
process tid prio (all id:s are in hex)
00000008 Steam.exe
0000004d 0
0000004c 0
0000004b 0
00000048 0
00000047 0
00000046 0
00000045 0
00000044 0
00000043 0
00000041 1
0000003e 0
0000003c 0
0000003b 0
00000033 0
00000031 0
00000030 0
0000002f 0
0000002c 0
0000002b 0
0000002a 0
00000029 0
00000009 0
0000000e services.exe
00000020 0
0000001f 0
00000017 0
00000016 0
00000014 0
00000010 0
0000000f 0
00000012 winedevice.exe
0000001e 0
0000001b 0
0000001a 0
00000019 0
00000018 0
00000013 0
0000001c plugplay.exe
00000022 0
00000021 0
0000001d 0
00000023 explorer.exe
00000028 0
00000027 0
00000026 0
00000025 0
00000024 0
0000002d steamwebhelper.exe
0000002e 0
00000034 (D) C:\Program Files\Steam\bin\cef\cef.win7\steamwebhelper.exe
00000038 0
00000037 0
00000036 0
00000035 0 <==
System information:
Wine build: wine-2.0.2 (Ubuntu 2.0.2-2ubuntu1)
Platform: i386
Version: Windows 7
Host system: Linux
Host version: 4.13.0-32-generic


#10

looks like the stack trace for Steamwebhelper.exe so, no, this does not help.

The game seems to be working fine based on the WineHQ test results; https://appdb.winehq.org/objectManager.php?sClass=version&iId=29915


#11

I did a Google search on one of the error messages. "PE 7e860000-7e863000 Deferred dxva2’ and found that it was a hardware acceleration error. DXVA 2 Windows Vista EVR (DirectShow and Media Foundation) I tried switching to Vista, but the game still crashed after 3M55S95mS as timed by my watches chronometer. PlayOnLinux can run it. What’s wrong with Lutris Gaming?


#12

I got it to work a bit more. It crashes before I can get my character into the game.


#13

I have tried 4 wine games and none of them are very successful. It looks like Lutris gaming is an epic fail! To bad POL is dying. At least POL works.


#14

I checked the log for the last game. Banished. Aside from wine builder, it also said:
[0129/190815:ERROR:network_change_notifier_win.cc(170)] WSALookupServiceBegin failed with: 8


#15

Anybody got any idea of how to get this to work?


#16

you might wanna enable more thorough debugging in the “Runner options” so you actually get a log to show us so we can help you fix it

PlayOnLinux can run it. What’s wrong with Lutris Gaming?

nothing, they’re doing exactly the same: running wine the way you told them to. so I suspect a layer 8 problem.

I have tried 4 wine games and none of them are very successful.

which are they and how did you try them and how unsuccessful were they? all you did was post “it doesn’t work” without any detailed information.
Or, as my dad used to say: “‘It doesn’t print; I’ve done nothing!’ is NOT a support ticket”

It looks like Lutris gaming is an epic fail!

actually it’s really great and I’ve found only one problem with it so far, which is libretro not working because of some esoteric library they depend on which conflicts with my system’s version of it.

To bad POL is dying. At least POL works.

agreed, always bad to see open source projects die, but lutris worked way better for me than POL so far, I’ve even migrated all my POL stuff over to lutris. (and POL’s approach of being a bunch of badly maintained shell include files that prevent each other from working correctly and actively sabotageing winetricks wasn’t the best either :P)

so maybe stop whining about how the big company that lutris IS NOT RUN BY and that you DID NOT HAVE TO pay for it is SO EVIL FOR not providing 24/7 magic mind-reading support, but instead give the devs some respect for what they actually achieved here and us some actual info on what’s going on so the community can actually try to help you.

btw googling for random “deferred …” stuff and then thinking “it’s an hardware accell issue” kinda sums up your approach to this so far IMO, since it wasn’t even an error message you picked that line from.

sorry for that rant, and if i can help you get it to work I’ll gladly do, but not providing any information and then getting pissed over people who do this for a hobby (and with most of them having no experience with your specific game or problem) not helping you fast enough is kinda rude, just sayin’


#17

This is all I can figure out to get from lutris for the last game log. wine: cannot find L"C:\windows\system32\winemenubuilder.exe"
[0312/030203:ERROR:network_change_notifier_win.cc(170)] WSALookupServiceBegin failed with: 8
wine: Unhandled page fault on read access to 0x00000000 at address 0x437b59 (thread 0043), starting debugger…
[0312/030357:ERROR:network_change_notifier_win.cc(170)] WSALookupServiceBegin failed with: 8

How do I get any more detail?

I sure will be relived when this gets solved. I am using wine 3.3 staging but it still quits after just a few minutes.


#18

right click, configure, runner options, output debugging info = enabled.

you do know what pastebin.com is, right? and even without that you could at least format it as code (the little </> button in the edit toolbar of this forum)