Audio devices missing from non-system Wine

I created a Pulseaudio virtual audio device to isolate game audio for OBS but it doesn’t show up when editing the game’s wine config, (using Lutris 7.1). It does however show up on the system’s Wine config along with every other audio device. I’m not sure where or how to add the missing audio devices. Any help?

this is one of the reasons why I have 2 pc’s one with a PCI capture card it’s so much easier but I understand not everyone has the money for 2 PC’s but it makes so many things easier when it comes to streaming.

As you may know the wine packages for the hames are independent so any changes need to be made to the wine_prefix.

With that out of the way, can you check the following in the game wine prefix:

winetricks settings list | grep sound

Also have a look here:

Additionally, consider installing pipewire, it may just work.

I think this is the game Wine prefix, I’m not sure.

~/.wine/drive_c$ winetricks settings list | grep sound
sound=alsa               Set sound driver to ALSA  
sound=coreaudio          Set sound driver to Mac CoreAudio  
sound=disabled           Set sound driver to disabled  
sound=oss                Set sound driver to OSS  
sound=pulse              Set sound driver to PulseAudio

I used this to create the audio device and it works with my system Wine, just need to find out how to select it in the Wine prefix.

I followed this advice and it just works, thanks!
Here’s the OBS plugin if anyone is interested

Cool, yeah pipewire is the new pulseaudio. It’s doing everything right so far. I had issues with pulse for my Bluetooth headphones and with pipewire just worked.