Attempt to install Vortex immediately fails before processing

I read the “please read” and I am not at a point where I can even run any games, so I could not complete all tasks. Kind of a newb with Lutris, if someone could point me toward how I could mimic this install from the command line, I will gladly provide that log also.

Issue: Immediately after triggering the Vortex install, I get the following error:
ffi_prep_closure():bad user_data(it seems that the version of the libffi library seen at runtime is different from the ‘ffi.h’ file seen at compile-time)

Here is the --submit-issue JSON:

I’m getting the same ffi_prep_closure error when trying to install Wine Steam, no idea why.

I’m running the same distro as you (Pop!_OS 20.10).

I get the exact same message, when I try to install any wine game :confused:
I upgraded to Ubuntu 20.10 one week ago. Maybe that’s part of the issue?

I’m unfortunately seeing this same error. I believe there’s some system glitch at play here.

I found the solution on lutris#3270. The issue may have been caused by the 20.10 upgrade.

It can be fixed by updating Python libraries to be compatible with the Lutris requirements. Downloading the file and running pip install -r requirements.txt worked for me.

Thank you, I will try this today.