Back to the main site

Assetto Corsa Help


#1

I am running Ubuntu 18.04, and Lutris 0.4.18.
I ran the Assetto Corsa DXVK Script. I can get the launcher to load only if I use xp in the wine config, Windows 7 or 10 the launcher will not load.
So in xp once the launcher loads and I select a practice section it just crashes, I ran lutris in the terminal and here is the results,
https://pastebin.com/VDX6TTVu

A side note, I have Battlefield 4 running perfectly.


#2

Same problem here. Someone on Reddit got it working by fiddling with enabling and disabling the Lutris runtime, it didn’t work for me. Others have suggested turning all graphics to the minimum, which kind of defeats the purpose for me…

BTW: Can you tell me how you got Battlefield 4 working? Feel free to message me to keep this tread focused.
I have origin installed, downloaded BF4, get a Direct X error at the end and it doesn’t think it’s installed. I manually installed DirectX and Punkbuster, but it won’t load. Thanks!


#3

Ok, got it! Turning down all of the graphics to the lowest setting did the trick! Afterwards, I was able to crank everything up at 3440x1440 to mostly max in graphic setting after graphic setting but kept off the anti-aliasing (something I found that lots of titles have problems with in Wine) without a problem. Amazing. Finally! Racing wheel works perfectly OOTB, including force feedback (although AC might be one of the more satisfying sims with keyboard as well). So, here’s the sequence of the specifics of what I did:

  • Used Lutris to make a 32 bit prefix. I assigned Wine 3.9-Staging (my system Wine) and DXVK 0.54 in the Lutris config for this program. The “Disable Lutris Runtime” box is NOT checked.
  • With winecfg set the prefix to Windows XP
  • Basically followed the installation procedure detailed in the description for this Youtube video. I did NOT use Lutris Winetricks. I did it all from the terminal there as the Youtube video outlines with two exceptions. I did not use the Winetricks dotnet. I downloaded the same dotnet version from the web and installed it with Wine. The second difference is I also downloaded the dotnet installation verify program (easily found Googling) and ran that with Wine and verified that dotnet was working.
  • Once that was done, I copied my basic template 32 bit Windows Steam install into that prefix, ran steam with it, and then launched Assetto Corsa.
  • At the launcher, I turned all the graphics down from above and everything works!

Please let me know if you have any questions.