Back to the main site

Assetto Corsa: dotNet 4.7.2 install timeout

Installation fails with the following repeating over and over:
003f:err:ntdll:RtlpWaitForCriticalSection section 0x100a8 “/home/ubuntu/buildbot/runners/wine/wine-src/dlls/ntdll/heap.c: main process heap section” wait timed out in thread 003f, blocked by 00ef, retrying (60 sec)

Mint 19.3
Wine Staging 5.10
Installed dotNet 4.8 in my home .wine no problem via winetricks
Any ideas?

I run AC from Steam using Proton. Does it run there?

Haven’t tried. I tried Nascar Heat 4 under Proton and got garbled graphics, but it works fine with Wine Steam.
I suspect that Proton will require dotNet as well, but I’ll give it a try.

Every game is different. Or as I like to call it, every game engine.

Sometimes installations will stall so it may be a case of just trying again…

Weird. I installed the Proton version, but it started downloading the game files, which I already have installed. Steam popped up with a notice Ialready had AC on my platform, so I cancelled Lutris download. Clicked on AC in Steam, and it installed Direct X. Now it’s busy doing somethingaccording to top…but I’m not sure what ;-0
Guess I’ll just wait and see.

…and now when I try to install Proton version Steam says it’s not available on my current platform. WTF?
Guess I’m stuck trying to resolve the dotNet issue.

Is that Windows-Steam (via Wine) or Linux-Steam from your system menu?

You should be able to do everything from Linux-Steam. Enable Steam-Play for all games from the Steam options, install AC and play. Nothing more.

My Linux Steam seems b0rken. System hangs, no panel app, wont exit without "kill -9 ".
I’ll try to re-install.

Clean re-install of Linx Steam, forced compatability for AC, launched and it couldn’t find AssettoCorsa.exe. There was an empty folder 'assettocorsa in the Linux Steam, I replaced it with a link to the game files in winesteam. Now it launches and fails with no message.

I’ve tried editing the winesteam install script to dotNet 48 and using test, but it still tries to install dotNet 472 and times out at the same spot.

Playing around with winetricks I found out this is not an error per se, it is what happens when a dialog box pops up and the program is waiting for input.

Isn’t there a “pop-under” somewhere? That happens sometimes when I install a game.

I don’t know, didn’t think about that. It did eventually install dotNet472, so that may have been what was happening. Still didn’t work. However I did manage to get it working with Proton. I installed dotNet via ProtonTricks and it now runs perfectly.
Thanks for your help.