Assassin's Creed II starts, then closes

I’m an experienced Linux user, but am fairly new to gaming on Linux. I recently installed Steam in Linux and have been enjoying some native/Proton games/demos. I more recently bought Assassin’s Creed II on Steam but couldn’t get it working through Steam directly (the same “cannot retrieve a license key” issue others have been having). But I read that people have had success with Lutris…

I installed Lutris (and Wine) and have successfully installed ACII in Lutris using the Windows Steam version. UPlay works and retrieves the key correctly, and the game actually starts, but within a few seconds it closes again (and then I have to press the ‘Stop’ button in Lutris in order to close UPlay and Steam (which are still running)).

I’m hoping someone can help me debug my setup to work out what’s causing the game to close.
Here’s my issue report:
And my lutris -d output:


Apparently new forum users can only put two links in a post… So here’s my game’s log:

Oh, and here’s a screenshot of the game window right before it closed:

Good day. I am a total Linux noob. but I might have an idea on how to possibly get something working. On steam, you can try different proton versions like TKG or GE

On Lutris. I believe the better way will be to install Uplay first on Lutris and then install assassins creed from Uplay. I have found that windows steam rarely works an I don’t even try anymore.

For all I know, They fixed it. So far I had no need to go check.

My solution might not work as I am using Linux for only 3 months now as my main driver.
I also do not own any assassins creed game, so for me to test my possible solutions is impossible.

Please let us know whether it worked and feel free to ask if you have any questions unanswered.

Also. Just as a side note. Personally, I have rejected the way they demand information to be uploaded. At the top of the text bar is some functions that I find is alot more useful and intuitive.

For instance:

My current system:

[ferret@ferret-ms7b07 ~]$ neofetch
██████████████████  ████████   ferret@ferret-ms7b07 
██████████████████  ████████   -------------------- 
██████████████████  ████████   OS: Manjaro Linux x86_64 
██████████████████  ████████   Host: MS-7B07 1.0 
████████            ████████   Kernel: 5.8.15-xanmod1-1 
████████  ████████  ████████   Uptime: 3 days, 10 hours, 11 mins 
████████  ████████  ████████   Packages: 1358 (pacman) 
████████  ████████  ████████   Shell: bash 5.0.18 
████████  ████████  ████████   Resolution: 1366x768 
████████  ████████  ████████   DE: Cinnamon 4.6.7 
████████  ████████  ████████   WM: Mutter (Muffin) 
████████  ████████  ████████   WM Theme: Matcha-dark-aliz (Matcha-dark-aliz) 
████████  ████████  ████████   Theme: Matcha-dark-aliz [GTK2/3] 
████████  ████████  ████████   Icons: Adwaita [GTK2/3] 
                               Terminal: terminator 
                               CPU: AMD Ryzen 3 3200G (4) @ 3.160GHz 
                               GPU: AMD ATI 29:00.0 Picasso 
                               Memory: 6686MiB / 9962MiB 


[ferret@ferret-ms7b07 ~]$ 

The above part was achieved by pasting what was in my terminal and then highlighting it and pressing the preformatted text button.

Feel free to play with the buttons and see on the right hand preview what it would look like.

Thanks for the assistance @Ferrator. Unfortunately, installing a custom version of Proton doesn’t work - I still get the same “Failed to request product key from Steam” error when trying to launch the game from Linux Steam.

And installing UPlay first through Lutris, then installing/running ACII from there doesn’t work either - it still freezes/closes on the first logo screen.

I feel like I’m so close to getting this working… Anyone able to help?

I have a similar problem with AC 1 (Gog version).

The game launches and crash after 2 seconds of video. it still freezes/closes on the first logo screen.

I try different system (WIne/Proton…) but nothing more.