Back to the main site

Assassin's creed ii on uplay

Hello, I am attempting to run Assassin’s Creed II Uplay version using the lutris runner. I’m on Arch, as far as I can tell I’ve installed all the relevant packages but . I am unable to login to my uplay account when the game is launched - I get a no network connection error. I have tried disabling the runner and using different versions of Wine back to 5.0. The terminal output is below. Any help would be greatly appreciated. Thank you!

Exception ignored in: <function InputDevice.__del__ at 0x7efef0125160>
Traceback (most recent call last):
  File "/usr/lib/python3.8/site-packages/evdev/device.py", line 159, in __del__
    self.close()
  File "/usr/lib/python3.8/site-packages/evdev/device.py", line 304, in close
    super().close()
  File "/usr/lib/python3.8/site-packages/evdev/eventio_async.py", line 54, in close
    loop = asyncio.get_event_loop()
  File "/usr/lib/python3.8/asyncio/events.py", line 639, in get_event_loop
    raise RuntimeError('There is no current event loop in thread %r.'
RuntimeError: There is no current event loop in thread 'Thread-20'.
2020-06-03 14:12:02,363: Replacing /home/patrick/Games/assassins-creed-ii/drive_c/windows/system32/dxgi with DXVK version
2020-06-03 14:12:02,364: Replacing /home/patrick/Games/assassins-creed-ii/drive_c/windows/system32/d3d11 with DXVK version
2020-06-03 14:12:02,365: Replacing /home/patrick/Games/assassins-creed-ii/drive_c/windows/system32/d3d10core with DXVK version
2020-06-03 14:12:02,366: Replacing /home/patrick/Games/assassins-creed-ii/drive_c/windows/system32/d3d9 with DXVK version
2020-06-03 14:12:02,367: Replacing /home/patrick/Games/assassins-creed-ii/drive_c/windows/syswow64/dxgi with DXVK version
2020-06-03 14:12:02,367: Replacing /home/patrick/Games/assassins-creed-ii/drive_c/windows/syswow64/d3d11 with DXVK version
2020-06-03 14:12:02,368: Replacing /home/patrick/Games/assassins-creed-ii/drive_c/windows/syswow64/d3d10core with DXVK version
2020-06-03 14:12:02,369: Replacing /home/patrick/Games/assassins-creed-ii/drive_c/windows/syswow64/d3d9 with DXVK version
lutris-wrapper: Assassin's Creed II
Running /home/patrick/.local/share/lutris/runners/wine/lutris-5.7-x86_64/bin/wine /home/patrick/Games/assassins-creed-ii/drive_c/Program Files (x86)/Ubisoft/Ubisoft Game Launcher/Uplay.exe uplay://launch/4/0
Initial process has started with pid 30932
Game is considered started.
esync: up and running.
Initial process has exited.
info:  Game: upc.exe
info:  DXVK: v1.7-1-g84bb768a+
info:  Built-in extension providers:
info:    Win32 WSI
info:    OpenVR
warn:  OpenVR: Failed to locate module
info:  Enabled instance extensions:
info:    VK_KHR_get_surface_capabilities2
info:    VK_KHR_surface
info:    VK_KHR_win32_surface
warn:  D3D9: VK_FORMAT_D16_UNORM_S8_UINT -> VK_FORMAT_D24_UNORM_S8_UINT
info:  GeForce GTX 1070:
info:    Driver: 440.82.0
info:    Vulkan: 1.1.119
info:    Memory Heap[0]: 
info:      Size: 8192 MiB
info:      Flags: 0x1
info:      Memory Type[7]: Property Flags = 0x1
info:      Memory Type[8]: Property Flags = 0x1
info:    Memory Heap[1]: 
info:      Size: 11884 MiB
info:      Flags: 0x0
info:      Memory Type[0]: Property Flags = 0x0
info:      Memory Type[1]: Property Flags = 0x0
info:      Memory Type[2]: Property Flags = 0x0
info:      Memory Type[3]: Property Flags = 0x0
info:      Memory Type[4]: Property Flags = 0x0
info:      Memory Type[5]: Property Flags = 0x0
info:      Memory Type[6]: Property Flags = 0x0
info:      Memory Type[9]: Property Flags = 0x6
info:      Memory Type[10]: Property Flags = 0xe
warn:  D3D9: VK_FORMAT_D16_UNORM_S8_UINT -> VK_FORMAT_D24_UNORM_S8_UINT
info:  GeForce GTX 1070:
info:    Driver: 440.82.0
info:    Vulkan: 1.1.119
info:    Memory Heap[0]: 
info:      Size: 8192 MiB
info:      Flags: 0x1
info:      Memory Type[7]: Property Flags = 0x1
info:      Memory Type[8]: Property Flags = 0x1
info:    Memory Heap[1]: 
info:      Size: 11884 MiB
info:      Flags: 0x0
info:      Memory Type[0]: Property Flags = 0x0
info:      Memory Type[1]: Property Flags = 0x0
info:      Memory Type[2]: Property Flags = 0x0
info:      Memory Type[3]: Property Flags = 0x0
info:      Memory Type[4]: Property Flags = 0x0
info:      Memory Type[5]: Property Flags = 0x0
info:      Memory Type[6]: Property Flags = 0x0
info:      Memory Type[9]: Property Flags = 0x6
info:      Memory Type[10]: Property Flags = 0xe
warn:  D3D9: VK_FORMAT_D16_UNORM_S8_UINT -> VK_FORMAT_D24_UNORM_S8_UINT
info:  GeForce GTX 1070:
info:    Driver: 440.82.0
info:    Vulkan: 1.1.119
info:    Memory Heap[0]: 
info:      Size: 8192 MiB
info:      Flags: 0x1
info:      Memory Type[7]: Property Flags = 0x1
info:      Memory Type[8]: Property Flags = 0x1
info:    Memory Heap[1]: 
info:      Size: 11884 MiB
info:      Flags: 0x0
info:      Memory Type[0]: Property Flags = 0x0
info:      Memory Type[1]: Property Flags = 0x0
info:      Memory Type[2]: Property Flags = 0x0
info:      Memory Type[3]: Property Flags = 0x0
info:      Memory Type[4]: Property Flags = 0x0
info:      Memory Type[5]: Property Flags = 0x0
info:      Memory Type[6]: Property Flags = 0x0
info:      Memory Type[9]: Property Flags = 0x6
info:      Memory Type[10]: Property Flags = 0xe
info:  Process set as DPI aware
[0603/141208.497:ERROR:network_change_notifier_win.cc(157)] WSALookupServiceBegin failed with: 8
[0603/141209.145:ERROR:viz_main_impl.cc(201)] Exiting GPU process due to errors during initialization
[0603/141209.161:ERROR:service_manager_context.cc(250)] Attempting to run unsupported native service: C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\content_gpu.service.exe
[0603/141209.455:ERROR:viz_main_impl.cc(201)] Exiting GPU process due to errors during initialization
[0603/141209.466:ERROR:browser_gpu_channel_host_factory.cc(119)] Failed to launch GPU process.
[0603/141209.466:ERROR:gpu_process_transport_factory.cc(1026)] Lost UI shared context.

I was able to solve this by installing lib32-gnutls.