Assasin's Creed Valhalla crashes after Ubisoft June 27, 2022 update

Assassin’s Creed Valhalla worked flawlessly until the Ubisoft update on June 27, 2022. After the update ACValhalla.exe runs for about 10 seconds taking 500% CPU time and the crashes with Error[Crash]: Reason: Exception Caught at 0x00000000020B0632 (Violation when reading address 0x0000000000000048).
Apparently the update found a weak spot in Lutris/Wine/Proton.

run with wine lutris-GE-Proton7-24-x86_64 log:

run with wine lutris-ge-6.16-1-x86_64 log
Ubuntu Pastebin



I’m in the same situation running it on a Steam Deck.
In the Proton log I’ve found exactly the same error line as you:

Error[Crash]: An Exception has been detected by Bloomberg and a report will be sent.
Error[Crash]: Reason: Exception Caught at 0x0000000002110632 (Violation when reading address 0x0000000000000048)

I’m surprised the issue isn’t much discussed online, this is the first place in days where I’ve found it!

1 Like

I have the same issue… i also have tried lutris-GE-Proton7-24-x86_64 and lutris-ge-6.16-1-x86_64.
does anyone have any idea how to fix this?
also detected by Bloomberg !?!?!

well… i was going to get a DLC… i guess i’m not now…

Hello again,
I’ve found today a workaround by franken-building the uConnect application.
After backing up the current installation, I’ve downloaded the previous version (Download Ubisoft Connect 130.1.10667 for Windows |, opened it as a ZIP archive and taken out just the updated files:


I’ve put these files in the current installation and restarted uConnect. It worked. I’m playing again with AC: Valhalla now.
I hope it may be useful in the meantime.

it’s franken-building but it works…

Hi guys, can anyone confirm that only replacing overlay64.dll is enough to make the game works.

This issue also happened to Immortal Fenyx Rising, downgrading overlay64.dll make it works again.

1 Like

I was able to also confirm that replacing the overlay64.dll was enough to get the game working.

I didn’t download anything though to get it to work. Below are the steps that I took.

  1. Locate your Ubisoft folder,
  2. Locate overlay.dll and overlay64.dll
  3. Back backups of both files;
  • cp overlay.dll overlay.dll.bak and cp overlay64.dll overlay64.dll.bak
  1. Delete overlay64.dll
  2. Rename overlay.dll to overlay64.dll
  • cp overlay.dll overlay64.dll

After doing this, I had no issues launching AC: Valhalla.
The only other games that I have installed are AC: Odyssey and Far Cry 6 and they both launched without any issues, after making this change.


Thank you very much sir!
This simplified a lot the fixing after the latest Uplay update! :smiley:

wow thanks for this long discussion leading me to disable the in-game overlay in settings and instantly fix the game not launching… lol

What means cp ? Thanks :smiley:

I backed up and renamed the files from the CLI, cp is the copy function.

1 Like

Disable overlay also works, but without it you can’t access ubisoft store from within the game, downgrading retain overlay & store functionality.

Another way to disable overlay64.dll is by disable it with env variable WINEDLLOVERRIDES="overlay64.dll=".

Or with lutris :

1 Like

After your overlay solution and launch, I got slow-motion running problems. Finally working.
I installed with Lutris and launch throught Steam with Proton.

But first, I have to type in Terminal:

sudo nano /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT=“intel_pstate=disable” ( FOR INTEL )

Save it and after that

sudo update-grub

Now I am running on 55 FPS and high details without any issues.
You can disable Overlay also in Ubisfot Connect app directly.
Check my gameplay sample:

Not AC Valhalla but in Immortals Fenyx Rising instead downgrading overlay64.dll I disable dinput8.dll with WINEDLLOVERRIDES="dinput8.dll", it no longer crash and the overlay remain working.

1 Like

this looks to be working!

Am i the only one who gets frozen black screen(or sometimes 1-2 seconds of game screen) after loading the game or benchmark?
Haven’t been able to play ACV for a year or so… Tried different distros, no luck. On win10 works well.
Tried enabling vsync and 30fps cap. That got the game actually working but with horrendous performance and frequent crashes.
Any ideas how to get this thing to work?

well…back to windows then. Linux is simply broken