Back to the main site

Are you guys thinking to add Medal of Honor: Warchest on Lutris?


#1

Recently I was playing Medal of Honor: Warchest the version on GOG on Windows 10 and I would love to continue to play it. It isn’t on Lutris but it has all the other ones. What is missing is the Allied Assault, Spearhead, and Breakthrough. So I thought it would be cool if you could add all of them unless it isn’t possible. It worked quite well on PlayOnLinux when I was on the distro ZorinOS 9 but since I went for Kubuntu 17.10 it doesn’t work anymore. So yeah I would be happy if there is a way to make it work. Thank you.


#2

Have you tried using GOG Galaxy (1.2.17.9 version) and installing through that?

I can make an installer but I’d need Allied Assault’s exe file path since I don’t have it. Otherwise the installer will just create an empty game launcher.


#3

Yeah I opened GOG 1.2.17.9 through Lutris and installed the game from there. All the games does is it launch and you will see a gray color and that’s it, and your resolution gets all messed up so you have to fix your display after that. I can send you the game if it’s okay I wouldn’t mind. also tried multiple wine versions and still nothing, there’s some that won’t launch at all, and others that will open the blank screen.


#4

That’s not necessary I just need the file path to the game’s exe. Look in the prefix for GOG Galaxy. Something like:

~/Games/gog-galaxy/drive_c/Program Files/GOG Games/Medal of Honor/medalofhonoralliedassault.exe


#5

In my case I didn’t install it in drive_c. Mine is set to Home/Games/Medal of Honor - Allied Assault War Chest/ then there’s MOHAA.exe, moh_spearhead.exe, moh_breakthrough.exe


#6

Well that kind of helps but since I don’t know the exact file path the installer might not work. Anyway, I made one can you see if it works? If not please re-install the game through GOG Galaxy and let it place the game folder itself. Then tell me the file path so I can update the installer.

You have to click Show unpublished installers in order to install it:

https://lutris.net/games/medal-of-honor-allied-assault-war-chest/


#7

Ok sure I will let you know soon, the installation worked but still didn’t launched. I don’t know if it might help you but the game was made with the engine id tech 3. Anyway will reinstall it and tell you the correct path.


#8

C:\Program Files\GOG Galaxy\Games\Medal of Honor - Allied Assault War Chest.


#9

Can you try the installer again? Instead of clicking Install this time click the arrow and Edit installer. Choose the latest draft version [draft] mohaa by cxf on 2017-11-29 22:40:47.679700 scroll down and click Test this installer.


#10

Alright will try it again.


#11

Still doing it again, I recorded it and tried three wine versions running in a virtual window and the last attempt I done it in fullscreen https://www.youtube.com/watch?v=osVS4vty52o&feature=youtu.be - and I’m sorry I saved a draft by accident but I did used the last one you suggested.

Tomorrow I will try RTCW and see if it does the same thing.


#13

Okay just updated the installer once more [draft] 2017-12-01 2:59:36. You can go ahead and delete the previous installs as they won’t be needed.

Hope it works. :crossed_fingers:


#14

:crossed_fingers:

EDIT: It’s still doing it, let me try another game that runs with this engine I will give you news soon.


#15

Even Return to Castle Wolfenstein doesn’t work, same engine and same issue, Gray screen and that’s it. So I bet Quake 3 Arena wouldn’t work either.


#16

Hello everybody, this is my first post here and i’m not sure if it fits here, but i’ll go ahead. If it’s in the wrong place, the admins can move the post.

I’ve installed Mohaa WarChest today (bought it first on GOG). The game runs the first time, no problem, but when i try to launch it again, the platform says that there are no files present. But the files are there, in the path the installer showed in the beginning. I know it’s a work in progress, but if there’s a fix already available, i’d like to know.

Thanks for the help!