[Arch] WOW/Battle.net Refreshing-Error

Hey Guys,
I have little bug with BattleNet.
I installed WOW on two machines. One is a friends machine and has Manjaro on it and one machine has Arch installed. Both use the latest lts-kernel and nvidia-lts. And both are installed on the same way with all needed dependencies from https://github.com/lutris/lutris/wiki/Game:-Blizzard-App and https://www.gloriouseggroll.tv/how-to-get-out-of-wine-dependency-hell

On Arch I have a weird bug that my Battle .net lobby keeps it’s content refreshing. So I cannot see any “news” or this little window where I can see who is online. Also it is not possible to read any chat messages. And that’s what makes this bug so annoying. Maybe someone here has a solution or idea what could cause this problem.

I started lutris in both cases within the terminal to see what error messages are ocurring.

[myc@Manjaro-PC ~]$ lutris
INFO 2018-03-28 18:38:13,180 [lutriswindow]:Connected to lutris net as zummsel
wine: Unhandled exception 0xc0000417 in thread 93 at address 0x523586 (thread 0093), starting debugger…

[zummsel@Arch-Desktop ~]$ lutris
INFO 2018-03-28 21:47:07,904 [lutriswindow]:Connected to lutris net as zummsel
wine: Unhandled exception 0xc0000417 in thread 83 at address 0x523586 (thread 0083), starting debugger…
wine: Unhandled exception 0x80000003 in thread be at address 0x12759073 (thread 00be), starting debugger…
wine: Unhandled exception 0x80000003 in thread da at address 0x12759073 (thread 00da), starting debugger…
wine: Unhandled exception 0x80000003 in thread f0 at address 0x12759073 (thread 00f0), starting debugger…
wine: Unhandled exception 0x80000003 in thread 106 at address 0x12759073 (thread 0106), starting debugger…

In the case of Arch it repeats “wine: Unhandled exception 0x80000003…” infinitely.

Hope someone can help me.

Thanks in advance!

Best regards

Sounds like something you are missing that is installed in Manjaro…but what? MSCorefonts? Truetype 2.0+?

ttf-ms-corefonts, lib32-freetype2 and freetype2 are installed.
But I don’t thinks it’s the fonts fault. It is not a display error… more like an error which causes Wine or BattleNet to reload over and over again. It’s hard to describe. If you could see it then you would immediately see what I mean.

Moreover I tried around a bit and found something out.

While logging in during installation I can see above mentioned windows and everything seems to work fine.
After closing, finishing installation and restarting BattleNet it’s not working anymore.

Ahh furthermore: In the Lutris-BattleNet-Installer is mentioned that I should close the window before logging in and finish the installation before my first login. But this causes the same issues within the username/password screen. It would keep refreshing and the login-button would never appear. So I have only one shot to login during installation, save my data and login.


hmm, well, something is different or you would get the same behavior. Please let us know if you ever find out what it is.

did you try different window managers (especially one with and one without compositing) and using the wine windowed mode (if you set it to your fullscreen resolution it should actually just open as a fullscreen window without annoying decoration/taskbar/etc; I often do that for fullscreen games where the WM might have issues with “alt+tabbing” out of & back into the game, or where it messes with applications which try to do stuff like their window positioning on their own (i think battle.net does that) etc, often helps much.)?

the “refreshing over and over again” sounds like some kind of issue with compositing or your WM messing with it.

maybe do a short screencast (or, maybe even better because less interference with your graphics hardware: just record a short clip of it on your phone) to show us if we maybe just don’t get what you’re trying to describe

also try looking into what those crashing threads actually do (maybe bump up the debug output in the runner settings), sounds like it’s trying to display stuff and crashing half way through just to retry indefinitely

Tried some stuff. First tried some setting-changes in lutris and wine, but nothing changed. Tried windowed mode aswell.

I don’t think it’s the WMs fault. Tried there some setting-changes also and just installed and tried it on KDE which uses KWin instead of Xfwm. Still no change… :frowning:

I made a little GIF which shows whats happening.

Unfortunately, I don’t have any idea what you mean by “bump up the debug output in the runner settings”.
DuckDuckGo didn’t help in this case :-/


both xfwm4 and kwin support compositing, not sure whether or not they are enabled on your system though. also:

this should prevent issues with the compositor though, so i agree your WM is most likely not to blame.

that helped me much. first i thought more like flickering instead of this constant reload, but this looks like that thread that keeps crashing is supposed to fetch some information/etc and gets constantly restarted (also note how the thread number in your quoted error messages keeps increasing, that looks like a TID overflow waiting to happen :P)

Right click on the game in lutris -> configure -> runner options -> debug log: enabled (note: “Full” should only be used in extreme cases, since it slows down everything like hell, but “enabled” is usually enough to debug most stuff).

I already tried to add some libraries like Kerberos in wine configuration, but it seemed to make no difference. And the it still popped up in the next log as well.

Here is the logging output.



so it looks like the relevant parts per dying thread are:

01d7:fixme:kerberos:kerberos_SpInstanceInit 65536,0x7d97a3a0,(nil): stub
01d7:fixme:d3d:wined3d_dxtn_init Wine cannot find the txc_dxtn library, DXTn software support unavailable.
01d7:fixme:process:SetProcessDEPPolicy (3): stub
01d7:fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
01d7:fixme:ntdll:EtwEventRegister ({d2d578d9-2936-45b6-a09f-30e32715f42d}, 0x10f28c10, 0x13e57558, 0x13eb8408) stub.
01d7:fixme:console:AttachConsole stub ffffffff
01d7:fixme:gdi:GdiInitializeLanguagePack stub
wine: Unhandled exception 0x80000003 in thread 1d7 at address 0x12759073 (thread 01d7), starting debugger...

the most obvious line there is the 2nd one (d3d/txc).
check if you have the 64 AND 32 bit versions of libtxc_dxtn.so installed on your system.

I think both are NOT installed and I cannot find them in the repositories.
Can it be possible that they are kinda outdated and are not used anymore?
Only connection I found to be with ATI/AMD, but I have a NVIDIA GPU.

on a quick google for “libtxc_dxtni arch” I found: https://bugs.archlinux.org/task/56660
tl;dr apparently you need to install the whole mesa package (64 and 32bit again) because someone at the arch maintainer team thought it to be smart to bunch everything together into some driver you most likely don’t even need for your gpu…

Mesa and lib32-mesa were already installed in version 17.3.7
I just tried to build the git versions of mesa and lib32-mesa, which are in version 18.*, but after 5h of building
it just cancelled the building process with an error. :frowning:
The normal versions in the repos are already flagged as ‘outdated’. Version 18 should come very soon.
So I have to wait for a push to see if it makes a change.

But thank you so much for your time and effort here.
I highly appreciate your work and help.


There are 2 errors with Blizzard App that would pop up, if I hadn’t disabled error output in the installer (since people seem to find the popups annoying for reason, who knew?). It surpresses: SystemSurvey.exe error, and Battle.net Helper.exe error.

I think the refreshing on the Blizzard App is basically that the helper doesn’t work in Wine. It shouldn’t matter though, you should be able to start your games without it.

Here an short update:

I booted Manjaro from a Live-USB to see what they have pre-installed.
They use the same mesa version as Arch has right now.
Unfortunately, this makes me sure that an update to 18.* most likely will not change anything.
But there are some mesa packages, which I had not installed on Arch.
mesa-demos, mesa-vdpau and libva-mesa-driver (all in 64- and 32-bit).
Installed all on Arch aswell, but there was no change.

The difference is that I’m pretty sure that Manjaro uses their own modified nvidia driver.


Just tested some behaviour in game. And unfortunately it does not work at the moment.

This refreshing bug is annoying me, because it makes chat/social interaction impossible, but (and that’s even more important) it makes the keyboard unusable in game! It does not react at all.

On the other hand the mouse works fine and fps are great since 3.3-pba.


Honostly, I advise people to close Blizzard App after you start a Blizzard Game. It tends to keep trying to grab focus.

If you really need the Blizzard App, you could try to use the standalone Blizzard App install. This will install into a different prefix. Perhaps you can start that and use it for chat. And set the WoW install to launch WoW directly. (not saying this will work, but it something you can try)

I already knew that advise, but it didn’t change anything for me. So I preferred to keep it open.
Standalone installation didn’t change anything either.

But thank you both for your help.