Back to the main site

Anyone got Homeworld Remastered Singleplayer to work on Steam Wine?


#1

I have been trying to get Homeworld remastered to work on Lutris with Solus3 Budgie (using wine3.3-staging). See also here:
https://appdb.winehq.org/objectManager.php?sClass=version&iId=31973

After some tinkering the multiplayer and “classic” version of HW2 works, but there were several strange issues. First of all the winetricks to install the .NET Framework 4.0 part only works when when I disable the Lutris Runtime in the settings. After that the Launcher works, and I can start a multiplayer game fine (only tested the tutorials not the actual multiplayer).

But as written in the WineHQ page the remastered singleplayer campaigns need to be started with some launch parameters either manually or through the launcher. But both result in an access violation error.

After some searching on the net I found this remark:
https://www.gog.com/forum/homeworld_remastered_collection/homeworld_remastered_21_patch_problem/page2

Well I think I may have found a temporary fix for this problem. After the 2.1 patch, the game will not load unless you give Homeworld Remastered access to “home” which is 127.0.0.1. This is required even if one is playing offline. Version 2.0 didn’t have this issue.

Any idea how I could allow this with Lutris? Thanks!


#2

I’d be interested in this also.
(commented so I get any updates)


#3

okay,
after much playing with settings I seem to have got it working :confused:

I ran winecfg from inside lutris and changed the Windows version to “Windows 7” also installed Dotnet4.00 via winetricks in lutris
and I’m running wine 3.0-i386

I didn’t try multiplayer but the single player missions worked :smiley:


#4

Great, that exact setup does indeed work for me as well… thanks!


#5

my pleasure :slight_smile: glad it worked for you too