Back to the main site

Anthem graphical issues


#1

Hi, I am trying to run Anthem on Linux. I used the Lutris install script for now.
2 problems:

  1. Sometimes the game just quits without an error message during loading screens (esync off and wine 3.21 / 4.3 seems to be the trick here).
  2. Every time I can play, something is wrong with the textures or shadows in some open world areas that aren’t directly illuminate. They appear almost black. Changing in-game graphical settings has no effect on it.
    (For reference I also played on Windows 7 and I had non of these problems so I assume it is not a hardware thing.)

I wonder if some experienced similar issues in other games and maybe can give me some tips or narrow down the error reason(s). Maybe a known wine / dxvk bug or an unsupported graphics feature?
Thanks!


#2

Not sure if you got it working, but I’ve had a bit of luck getting it to run. Note, I have a Radeon RX480. Running Pop!_OS 19.04.

The installer has you use Win 3.21, but I found that it works best for me using tkg-protonified-4.5-x86_64. I have not had any luck when the in-game graphical settings were set to maximum, but set to medium I get decent fps.

I have tried wine 4.6 (tkg, base, profonified, etc) with no luck. Sticking with 4.5 for now.

Before when using 3.21, there was a lot of graphical lag… especially when it was loading textures. I also seem to remember seeing some texture glitches, but using the wine 4.5 mentioned above seems to have solved it for me.

I hope this helps.


#3

I’m curious what other settings you may have changed. I recently installed Anthem (came free with my GTX 2070) and the only version of wine that seems to work is 3.21. I haven’t tried all of the 4 series yet, but neither 4.3 base or 4.4/4.5 protonified work for me (Origin doesn’t launch).


#4

Since the most recent Anthem update (1.1.0 I think), I was having trouble with the Origin client. It would launch for me, but then it would want to “verify files” on Anthem… and crash about halfway through.

I was perplexed… but eventually I tried going back to the original 3.21-tkg-protonified that the original Origin script used… and that got further.

It did come up with the DirectX install failure which is noted in the Origin Games page here and following the directions to delete the specified DLL files did fix it for me: https://github.com/lutris/lutris/wiki/Game:-Origin

Once past that, I did launch the game and play a bit of Freeplay on the 3.21-tkg-protonified. It still feels a bit slower than the 4.5 to me, but that might just be a feeling, I don’t have any FPS setup to actually compare.


#5

There is a known bug with wine 4.6 and Origin: https://bugs.winehq.org/show_bug.cgi?id=47027

Wine 4.5 still works for me but even with the newest nvidia driver, DXVK and game version I still have the mentioned rendering issues.


#6

You guys seem to have luck getting the game to at least run. I was hoping someone could help me out. I keep getting lock ups anytime I go past the main menu I get this: https://i.imgur.com/KWJLYws.jpg. Any idea? After I let it sit there if it is full screen it will freeze everything to the point I have to hard reboot, if it’s small like that it will just error out.
I’m on the newest pop os and running 3.21-tkg-protonified for lutris origin.

*Edit It may have something to do with my OC on the crashing, but I’m still not sure how to get past that white screen. I’m “Updating” the game now but I think that’s just going to reinstall the files I deleted for the direct x tweak. I’ll report back either way.


#7

Melawen, I saw another thread that said that Origin was having troubles with old nVidia drivers. Maybe this will help you? See here:

LeBeast, I’m not sure why you’re having such troubles. I did have problems updating when I wasn’t running the 3.21-tkg-protonified, but you’re already doing that.


#8

pathway, thanks. I’m actually running the 430 drivers so don’t think it’s that. I have had a tinker around though. Disabling the Lutris runtime actually lets Origin start, but it either logs in as offline or crashes depending on which 4x protonified version I use. Still haven’t managed to start the game with anything but the 3.21 version.


#9

Forgot this thread was here. Just as an update for me, 4.8 protonified worked for me, and I can even use my xbox 360 wireless now (didn’t work in earlier versions) so that’s a bonue :slight_smile:

Hopefully the OP had similar success.