Back to the main site

[Antergos] League of Legends BugSplat


#1

Hello, I’m running on Antergos and wanted to play League Of Legends.
After installing it and trying to launch a game, I encounter a bugsplat, every time.

Also, it may be linked, I can’t launch Winetricks from Lutris, nothing happens.

Here is the error log of League :

Blockquote 000000.000| ALWAYS| Logging started at 2018-02-12T21:28:19.023
000000.000| OKAY| Riot::RADS::Reader::RadsMain::Initialize: RADS library initializing with specified working directory “C:\Riot Games\League of Legends\RADS\solutions\lol_game_client_sln\releases\0.0.1.202\deploy”.
000000.000| OKAY| Riot::RADS::Reader::RuntimeEnvironment::Create: Creating RADS runtime environment: RADS root directory = “C:/Riot Games/League of Legends/RADS”
000000.000| OKAY| Riot::RADS::Reader::SolutionManifest::Load: (“C:/Riot Games/League of Legends/RADS/solutions/lol_game_client_sln/releases/0.0.1.202/solutionmanifest”)
000000.000| OKAY| Riot::RADS::Reader::ConfigurationManifest::Load: (“C:/Riot Games/League of Legends/RADS/solutions/lol_game_client_sln/releases/0.0.1.202/configurationmanifest”)
000000.000| OKAY| Riot::RADS::Reader::ReleaseManifest::LoadInternal: (“C:/Riot Games/League of Legends/RADS/projects/lol_game_client_fr_fr/releases/0.0.1.116/releasemanifest”)
000000.007| OKAY| Riot::RADS::Reader::ReleaseManifest::LoadInternal: (“C:/Riot Games/League of Legends/RADS/projects/lol_game_client/releases/0.0.1.143/releasemanifest”)
000000.378| ALWAYS| Begin command line toggles…
000000.378| ALWAYS| -UseNewX3D = 1
000000.378| ALWAYS| -UseNewX3DFramebuffers = 1
000000.378| ALWAYS| End command line toggles.
000000.380| OKAY| Unable to process data overlay file ./ToolsConfig.xml, defaulting to overlay now
000000.380| ALWAYS| Data overlay start folder initialized to DATA, Content/Src
000000.401| ALWAYS| SEJ-8D9EAD84
000000.401| ALWAYS| Build Version: Version 8.3.217.1022 (Feb 02 2018/12:02:42) [PUBLIC] <MAIN> ChangeList: 2171022
000000.426| ALWAYS| OS Version String: XP Service Pack 3 Professional, x86
000000.426| ALWAYS| CPU: GenuineIntel, Intel® Pentium® 4 CPU 2.40GHz, x86 Family 6 Model 60 Stepping 3, 4400 (0 core)
000000.426| ALWAYS| Measured processor speed: 3964
000000.426| ALWAYS| Display info:
000000.426| ALWAYS| Physical memory: 0
000000.426| ALWAYS| {“messageType”:“hardware_information”,“message_body”:“Hardware Info”,“operating_system”:“XP Service Pack 3 Professional, x86”,“cpu”:“GenuineIntel”,“cpu_processor”:“Intel® Pentium® 4 CPU 2.40GHz”,“cpu_identifier”:“x86 Family 6 Model 60 Stepping 3”,“cpu_topology”:1,“gpu”:"",“video_memory”:"",“driver_version”:"",“physical_memory”:0,“wine”:true}
000000.426| ALWAYS| -----HARDWARE INFORMATION START-----
000000.427| ALWAYS| Operating System: XP Service Pack 3 Professional, x86
000000.427| ALWAYS| GPU Manufacturer:
000000.427| ALWAYS| GPU Memory:
000000.427| ALWAYS| GPU Driver Version:
000000.427| ALWAYS| CPU Brand: GenuineIntel
000000.427| ALWAYS| CPU Processor Name: Intel® Pentium® 4 CPU 2.40GHz
000000.427| ALWAYS| CPU Identifier: x86 Family 6 Model 60 Stepping 3
000000.427| ALWAYS| CPU Speed: 4400
000000.427| ALWAYS| CPU Topology: 1 Core
000000.427| ALWAYS| Physical memory: 0
000000.427| ALWAYS| -----HARDWARE INFORMATION END-----
000000.444| ALWAYS| Started System Init
000000.445| ALWAYS| LCURemotingClient: Initializing on port 45267
000000.575| ALWAYS| LCURemotingClient: Connected to app process.
000000.576| ALWAYS| zip manifest, ‘ClientZips.txt’, not found (expected).
000000.576| ALWAYS| WadFile mount: DATA/FINAL/Global.wad
000000.578| ALWAYS| WadFile mount: DATA/FINAL/Scripts.wad
000000.579| ALWAYS| WadFile mount: DATA/FINAL/ShaderCache.wad
000000.579| ALWAYS| WadFile mount: DATA/FINAL/UI/ui.wad
000000.580| ALWAYS| WadFile mount: DATA/FINAL/Shaders/Shaders.wad
000000.580| ALWAYS| WadFile mount: DATA/FINAL/Localized/Global.fr_fr.wad
000000.695| ALWAYS| StartSession called
000000.695| ALWAYS| Waiting until connection…
000000.815| ALWAYS| InitRenderer() enter
000000.816| ALWAYS| r3dRenderLayer::Init(0x000500B6) enter
000000.816| ALWAYS| r3dRenderLayer::Init() exit successfully
000001.018| ALWAYS| Loaded locale fr_fr via fontconfig
000001.022| ALWAYS| IME file, ‘C:/Riot Games/League of Legends/RADS/solutions/lol_game_client_sln/releases/0.0.1.202/deploy/Data/Menu/IMEConfig.xml’, is optional. The following error is expected.
000001.022| ERROR| Missing file on r3dGFile open :C:/Riot Games/League of Legends/RADS/solutions/lol_game_client_sln/releases/0.0.1.202/deploy/Data/Menu/IMEConfig.xml
000001.022| ERROR| Missing file on r3dGFile open :\Bin\Data\C:/Riot Games/League of Legends/RADS/solutions/lol_game_client_sln/releases/0.0.1.202/deploy/Data/Menu/IMEConfig.xml
000001.024| ALWAYS| SharedConfigPath: …/Air/preferences/
000001.026| ALWAYS| OptionsManager::ApplyAutoPerformanceSettings()
000001.026| ALWAYS| rr3dRenderLayer::InitDevice(XRes = 1024, YRes = 768, BPP = 32) enter
000001.026| ALWAYS| rr3dRenderLayer::InitDevice: Creating X3D device
000001.265| ERROR| Crash Occurred

Thanks !


#2

Ok, was my bad, I was missing wine-mono, really sorry…